"Missing plugin configuration"

We are prototyping a plugin. We started with per user api key, which worked as expected. Now we wanted to enable oauth2 authentication and updated the manifest

When we try to install that plugin we get an error “Missing plugin configuration” after the token validation step.

How can we fix this error?


1 Like

I tried both “is_user_authenticated”: true and “is_user_authenticated”: false - same result.

I didn’t find any information about that error message.

Does anybody have any ideas? Is there official developer support available?

@adenin have you had any luck resolving this issue?

It works with our prod domain name, but on our stage domain we still get that error. Only difference between both manifests is the domain name. So we still have no idea what causes it or how to get stage to work as well.

I’m seeing the same error, unfortunately.

Hey guys!

We have configured OAuth for dozens of plugins with our custom OAuth system.
We often get this error when we complete the “develop your own plugin” installation process.

However, the trick is to cancel the popup and open the “Install unverified plugin” popup. Then it works perfectly.

If it keeps not working, I suggest your verifying your OAuth flow/configuration.

PS: If that is something that could help, at www.pluginlab.ai we provide a full-featured member management system with OAuth that you can configure in 5 minutes without coding.

This worked for me too!

cancling the operation reight before ‘sign’ in then “Install unverified plugin”