Issue with Voice Chat- Unwanted Language Translation

Hello OpenAI Community,

I’ve been using the latest voice chat feature with ChatGPT (Android device) and I’m experiencing an odd issue. Despite setting my language to English, the system sometimes automatically translates what I say into Polish. I’m originally from Poland, but my spoken English is proficient, so it shouldn’t be a language recognition problem.

Additionally, I have set the language of my Android device to English as well, but this has not resolved the issue.

This doesn’t happen every time but is quite frustrating when it does. Has anyone else experienced this? Any tips on how to resolve it would be greatly appreciated.

Thank you!

1 Like

Same here.

My voice prompts in English are sometimes automatically translated into Japanese. I am using an Android device.

I have read the article below and have already selected “English” as “Main Language” option, but unfortunately, the issue has not been resolved.

https://help.openai.com/en/articles/7947741-why-is-my-voice-prompt-automatically-translated-to-a-different-language

1 Like

After the latest update, I think that the bug has been fixed, because I don’t have unwanted translation anymore. :grinning:

Unfortunately, even with the latest update (1.2024.066), this bug appears. I’m in Singapore and speak English (that’s what we natively speak when growing up). I have also set the main language to English. However, during speech to text, the app will almost 90% of the time auto translate my English spoken text to Indonesian text in the conversation. It is very annoying to keep needing to remind ChatGPT to reply to me in English.

Exactly the same problem here. On the latest iOS version. Language option set to English. Everything I say is being translated into Indonesian by default

1 Like

Happening to me too, voice message in english, and it puts the text in what appears to be welsh.