Issue with Using GET Requests in GPT-Builder Chat Application Development


We’re in the process of developing a chat application utilizing GPT Builder, aiming for a release on the OpenAI store. Our implementation relies on “GET” requests for various functionalities. However, we’ve run into an unexpected issue: employing GET requests with GPT functionalities seems to lead to problems. Specifically, whenever we attempt a GET request, the action terminates prematurely and returns an empty dictionary ({}). This issue is perplexing and is hindering our progress.

Has anyone else encountered a similar issue? Any insights or advice on how to resolve this would be greatly appreciated.

P.S. We’ve found that “POST” requests operate without any issues, offering the desired outcomes. Nonetheless, our requirement necessitates the use of GET requests to leverage the “always allow” option for actions within our application.

Attached image -

is an example that this also happens in OpenAI’s sample applications.

If I was beginning to troubleshoot this, I’d look at trying two things;

  1. Edit my GPT’s instructions to give me more verbose information when errors occur. What it tried to call, any parameters it generated values for, and what those values were.
  2. Review your GPT Schema. I’ve been able to use GET calls with my Atlassian integration without issue. If your POST is working, and your GET is not, I’m assuming there’s something in your Schema that is incorrect for your “GET” path, that you got right in your “POST” path.

We tried that, and GPT says it got “ClientResponseError” without any further elaboration. No values, empty JSON. That happens on our GET request and the weather example GET request. We can’t get and GET request to work.

Are you sure the request is invalid? In this case, I don’t think exists which is why its invaid

Typically for a Get request the params are included in the URL and nothing in the body, which is why I think OpenAI shows {}

Have not had any issues with my Get requests thus far