Issue with Uploading .md and .txt Files in Playground

It appears that there is a restriction on uploading certain file types, specifically .md (Markdown) and .txt (plain text) files, which are commonly used formats.
But these types should be allowed inside the warning message,

Could you /someone please confirm if this is an intentional restriction or an oversight? If it’s the latter, I would like to request that support for .md and .txt files be considered for future updates to the Playground’s capabilities.

testetd in Chrome and edge.

2024-03-09 18_27_22-Clipboard

1 Like

Works fine for me.

It could be that they look at the file and not rely on the extension.

Try renaming the file, taking away it’s extension and seeing if your OS can pick it u p.

Also try creating a text file with just a “Hello World!” and see if it uploads successfully



I have played around with the file. It’s a Jupyter-Python-Project. From Jupyter with multiple cells, I have created the markdown.

If “import nltk, spacy” inside for example in one cell, the md cannot upload,
If I insert other libraries, the script can upload.

#import requests_cache

import nltk, spacy

# IPython-Widgets und OpenAI für interaktive Funktionen

from IPython.display import clear_output, display, HTML

import ipywidgets as widgets

1 Like

OpenAI has some unwanted document inspection or validation going on when uploading to assistants. This reached peak of frustration with valid JSON being rejected at one point unless they were purposely malformed (and I wrote a JSON confuser to get them uploaded).


Wow. Yeah. Just tried to upload a simple txt document with this and it was refused.

Such a strange thing to block.


I think I can explain this:

Support for spacy is a bit broken, as it often requires you to download the specific models you want to use, which can’t be done (by GPT) because the code space doesn’t have access to the internet.



This is for my understanding, not a spacy-problem. You can use another imports with the same result.

And it’s a Markdown file. Nothing to support or import.

1 Like

You’re problem is likely a temporary bug caused by OpenAI updating the backend or various service outages, I’m expecting this to be solved rather quickly.

My last post was just a response to sir @RonaldGRuckus :laughing:

1 Like