Indefinite loading when localhost is used inside of ChatGPT 4 plugins

I was testing a new plugin for ChatGPT, but suddenly, after removing and adding my application back (modifying the yaml), I found myself waiting for it to get the plugin details from localhost. After about 1 hour of waiting, I attempted to run the Plugin Quickstart demo code found on the OpenAI Github page.
Which I also never got to work. I did not modify the Quickstart code, and I am able to access the localhost server with no issues and even query for the yaml file in a browser. I attached some pictures below for reference.

Any help or update on this situation would be very appreciated.

Did you set the right CORS settings? Looks like chatgpt has no access and no timeout either.

CORS was set correctly and working perfectly fine moments ago until randomly it stopped working? I did manage to fix the issue today by restarting my computer, very interesting issue though. It could be CORS (but the server was never restarted, nor any server side modifications made, just json and yaml editing), I will have to look deeper into it. If I find out why this is happening I will be sure to update this channel.

I have built plugins on a local environment where I have a tls cert made with mkcert.

e.g. https://app.local

And I just gave chatgpt the plugin definition, the todo example code and the openapi.yaml and asked it to create me a http proxy in python which worked.

So localhost:someport gets called and redirects the request internally to https://app.local.

I understand that’s most probably not the same issue here but still worth a try.

Maybe a firewall issue?

Well whatever the issue was, after some frivolous attempts at recreating the issue, it does not seem to want to crop up again. I have encountered some other issues, but they seem to be more common and specific (yaml, and such) which are mostly to due with the program itself and are not a topic of discussion here. I do not think it is a firewall issue, as that would imply that some firewall rule has been changed between the error and me rebooting my computer. I am still looking into it to see if I can find out why this happened. My best guess so far is that it tried authenticating with some backed component that is not visible to us that might’ve been timing out.