In ChatGPT 4 plus how do I access inpainting and outpainting

After the latest update I cannot seem to access the inpainting and outpainting abilities of dallE.

I have ChatGPT plus, the paid account, and DallE is not integrated with chatGPT which is great. I can make images using the text prompt but how do I access the legacy feature where i could select certain areas of an image with the DallE editor.

I used the app as well as browser interface but cannot seem to find the editor anywhere.

Any help?

4 Likes

It’s not available.

The old Dall-e 2 home page says that Dall-e 3 “will soon have image editing”, but I guess they got busy building Sora instead and don’t care anymore.

I get the strong impression in recent months that they don’t really care about ChatGPT at all - it’s really unreliable and full of bugs, and only seems to get worse.

I suspect ChatGPT isn’t really how they make money - most users are probably non paying, which would be the only rational explanation why they treat it like abandonware. I guess the API is how they make money, so most of their efforts probably go towards research rather than improving existing products.

Or maybe it’s just that they’re an API company first and don’t really have the talent to build UI/UX.

Who knows. Either way, I’m looking for alternatives… ChatGPT is kind of falling apart and they do not seem to care. :man_shrugging:

Inpainting feature is under active development atm and quite close to be released soon

What about Outpainting? I see a buggy version of Inpainting released now. But still no outpainting?

Soon is a quite abstract information…
I could have done this in my Fooocus instance, but I paid for a better rendering. Now, I feel like I’ve wasted my money.

My attempt is outpainting with gpt-4o.
I tried to instruct it by giving it exact json instruction for the DALL-E 3 but it fails:

{
  "prompt": "Extended prompt of original image",
  "image": "file-zBqVXoIUQa8UIGj388RwHO22",
  "mask": "file-IbMvOszyeDjm7fxSJ91FV5p3",
  "size": "1792x1024"
}

(“image” is reference of 1024x1024 file it generated, “mask” is my uploaded png file of 1792x1024 size with transparent left and right areas to be outpainted)

It encounters an “AceInternalException” trying to use it with DALL-E. I had to generate and upload the mask file myself because it’s py script also failed to generate/save it with same error. Maybe some enforced limitations on creating/using additional files?