Image generation stopped working!

This is really quite bad… already the API is quite frankly being documented poorly… announcements not working…

now for some reason, dall-e-2 images generation stopped working (have not updated node package)… getting 500 errors now…

so I updated the modules to 4.16.1, checked the documentation for the new dall-e-3 model and functionality… and my typescript throws error

Property ‘createImage’ does not exist on type ‘OpenAI’.

  1. How can you allow for older versions to fail when you introduce new one? Without announcing breaking changes… and urge to update before you introduce the changes?
  2. Why is new one not working???

Thanks for letting us know.

The product is still in beta, and the API is only a day old now, so I would give it some time. This is what happens when you’re on the bleeding edge of technology.

I haven’t checked DALLE2 API today, but you might check the status page. There is a difference in how you call DALLE2 and DALLE3…

What errors are you getting?

Please share your code so we can take a look and diagnose the issue.

Hello, I had this same issue and also was a bit disappointed. I solved the ‘createImage’ error by running these commands:

pip3 uninstall openai
pip3 install openai

Updating the package did not work for me I had to manually uninstall and reinstall.

in the most recent node module the method moved from:

openai.createImage({
  model: "dall-e-3",
  prompt: "a white siamese cat",
  n: 1,
  size: "1024x1024",
});

to

openai.images.generate({
    model: "dall-e-3",
    prompt: "a white siamese cat",
    n: 1,
    size: "1024x1024",
  });
1 Like

I am currently also not able to generate any images for hours now. For 4 hours i have gotten the following message:
Error creating image
I apologize for the continued inconvenience. It appears that the image generation feature is still not functioning correctly. Is Dalle down?