How to force a GPT to search in its Knowledge?

Hello,

I’ve created a GPT and uploaded 20 Markdown files under Knowledge. Each Markdown file is ~150 KB and concatenates 100 Markdown files of some internal, non-public documentation.

Web Browsing, DALL·E Image Generation, and Code Interpreter are not enabled.

The Prompt is:

This GPT has access to the files uploaded in Knowledge.

This GPT should always search in the files uploaded in Knowledge before answering.

If the GPT can’t find the answer within its Knowledge base, it will only reply that it could not find an answer; it will not try to provide an actual answer.

When I ask the GPT a question about a topic that does exist in the Knowlegde, it does not find the answer in the Knowlegde (it does not seem to look in the Knowledge) and just replies, “I couldn’t find an answer in the uploaded documents.”

How can I force my GTP to search in its Knowledge?

I think you need to enable code interpreter.

Also, I would structure your instructions as a workflow similar to this:

"You are a GPT called XXXXX.

Objective: Answer the user’s question but using ONLY the information from the documents uploaded to your knowledge.

Workflow:

  1. Search “specific document.docx” for the answer to the user’s query.
  2. If the answer was found, provide the user with the answer.
  3. If the answer was not found, say “I could not find the answer”.

Thanks, @izzyT. Enabling the code interpreter and updating the prompt did not help. I was exporting Markdown files from Docusaurus. A colleague solved the issue by uploading the website/build/search-doc.json generated by the Docusaurus build process instead of uploading the source Markdown files.

1 Like