High CPU Web Workers usage of ChatGPT when not is use

Refreshing the page after it starts chewing CPU seems to be enough. Would be better if it was fixed, though, obviously. It always starts chewing CPU again after even just one or two responses, heh.

edit: I take that back. It takes minutes, plural, for it to complete a response now, even if I refresh the page after every response.

featuregates .org is the reason for high cpu usage.

I don’t understand. Would you mind explaining a bit?

that domains is used in chatgpt, it is the cpu gobbler.
google the “domain + chatgpt” there is github repo everything-chatgpt. its explained in detail.

Tried that after your explanation. Made no difference here, so I guess there’s more than one reason it is chewing CPU. It’s still doing the same here.

did you used ublock? install no-script and make it look like this.
my default is block script on any domain. this plugin will break websites

ns
only allow
openai .com
intercom .io
oaistatic .com
rest block em (remove the space from domain names)

Wouldn’t putting it in hosts with it pointed to 127.0.0.1 accomplish the same thing?

yes but at dns level, if you have pihole YES , your browser and os is set to it
the hosts file dont work well with DNS-over-TLS/HTTPS / dnscrypt

hosts file was good for HTTP requests if your OS is your DNS server

ok, I tried your no-script idea but it made no difference that I could tell. It still sits there chunking CPU like crazy for a minute or two before the stalled response “typing” wakes up again and BAM I have a complete reply. Same behaviour as without no-script.

that is very odd,
im on mac, both chrome and opera had same issue starting a few days ago. i blocked the scripts and its gone.

what os and browser are you using?
how old is your machine?
if you are on windows i recommend opera GX (gaming version), it has CPU and Ram limiter in the side bar.

Intel I9-12900KS
64 GB DDR5-5200
Windows 11
Chrome

Seems to me that limiting CPU usage is only going to make it take even longer. I gave up on keeping one conversation in a single conversation thread now, despite it being more convenient. Makes it much easier to go back and refer to stuff, but when it’s making a single response take ~5 minutes it goes beyond being outweighed by the amount of time wasted. Until they fix it I’ll just be starting a new thread as soon as it starts acting goofy again.

try this. setting core limit for chrome
maketecheasier .com/assign-specific-cpu-cores-apps-windows

did you purge your browser cache after installing no-script?
after purging, close chrome. kill any chrome tasks running. run it again

When it is going to do whatever it is going to do it doesn’t make any sense to me to limit the CPU resources available to it, as that will only make whatever it is going to do take longer to complete. I’m not concerned that it is maxing out one or two threads out of 24. I am annoyed that the entire job takes 5 minutes to complete when it should only take 15-30 seconds. I see no reason to do anything related to the cache, as shift-F5 should suffice.

Looks like there is some throttling on the page Heap and GPU usage as if some of the processing is merged. Which is why wiping the session is the best solution.

I think it’s safe to say that OpenAI in general isn’t the most competent at designing efficient, stable, compatible web-based systems.
So this could just be an oversight. If I were a really nasty conspiracy theorist, I’d say they’re using everyone’s CPUs to offload training work into the “cloud” :smile:

gpt
Same thing here. Tried different web browsers but it’s all the same

Same situation for 3 2 days. Cleaned cookies, tried different browsers, PCs, nothing helps.

ChatGPT is currently experiencing a significant problem with high CPU usage. Simple API calls are consuming all available CPU resources, causing delays of 1-2 minutes for responses. During this time, the CPU is at 100% usage, making the service almost unusable. This situation feels off, and it seems like client CPUs are being used for additional processing. We need a fix for this issue urgently.