High CPU Web Workers usage of ChatGPT when not is use

Hey folks, jumping in on this, the team is aware and actively looking into this. It would be great if anyone has a setup where they are able to consistently reproduce this.

Any details about how you get into the situation, how long the tab was open, or what actions you took on the tab would all be useful details for us to investigate more.

1 Like

Nothing special, just leaving the tab open for 15-30 minutes after having called “Empty Cache and hard reload” cpu usage raises above 100% and computer becomes hot, I can collect and share Performance snapshot once I stumble into this problem once again. It should provide you with some traces.

1 Like

My CPU usage is spiking to 70% when I have two ChatGPT tabs open for a while, the fans running at full speed and the computer starts to overheat, battery consumption is through the roof. I started getting this in the last couple of days fix this!!

What do you need from us? I have an M2 Mac showing Google Chrome Helper (Renderer) at 300% CPU after some time. Still not resolved.

1 Like

here it was easy as follow :
at 23:28 i opened a new tab and logged at chat gpt - no other interaction there
at 23:29 i moved to this tab and let it be for a few minutes
at 23:35 i moved back to chat gpt tab, no cpu spike
at 23:36 i moved to this tab again, i took the browser out of focus by clicking at the desktop
at 23:37 i moved back to chat gpt tab and the spike kicks in
… so 5 minutes and few clicks away was enough to trigger in a clear chat and no user interactions with the AI, running in a w10 + firefox setup

I have recorded performance profile which can be easily loaded into Chrome DevTools and reviewed by your team. How do I share it as I’m not able to share links?

Issue reproduced on both Brave and Chrome. Just leave the page open for some time.

Looking into the profile it’s apparent that your react app is in infinite async loop attempting to identify the programming language for ChatGPT output message that is currently being presented and apply corresponding formatting to it.

The code is obfuscated it’s hard to say anything else.

2 Likes

Same problem, on Firefox and mull browser, it waits for like 5 minutes then starts using a lot of cpu when im not looking. I turned off internet then CPU usage stopped in about 5 minutes. almost killed my pc.

1 Like

omg

1 Like

Steal have this problem
image

This should be fixed now! You’ll need to refresh your tabs that have ChatGPT open to get the latest version.

We will keep monitoring so please let me know if anything shows up in the meantime. Thanks for all the debugging and suggestions.

6 Likes

Hello, @logankilpatrick .
It seems that the problem was gone. I placed a ChatGPT tab in the background for an hour, and my CPU usage was normal. Thanks for your work.
(Firefox 120.0-1 on Manjaro Linux 23.1.0)
Regards.

The problem seems to be solved on Ubuntu 20.04 and Chrome 119. After an hour, the background TAB does not use any CPU.

I wonder what the environmental impact of this weekend was, with 100 million users having their CPUs at 100%. :sweat_smile:

Thanks!

1 Like

The problem seems to have been fixed now, thank you @logankilpatrick


This is a very serious issue and should be fixed ASAP!

It’s not really fixed. You seem to have stopped it from continuing to chew CPU cycles after a response has finished sending, but while it is still in the process of calculating and sending the response the web page is still chewing tons of CPU and becoming unresponsive. I’ll sit there and wait for quite a while for it to start sending the response like it normally does, but the web page becomes unresponsive and CPU usage for it is pegged, it doesn’t start sending the response as if someone was on the other end slowly typing it as usual. It might show a little bit of typing, but that display will stall. And then, just all of a sudden, BANG, here’s the remainder of the entire response already complete, all at once. Only once that’s done does the CPU usage die off. All of this is new behaviour over the last 3-4 days or so. So it no longer continues to chew CPU after receiving a complete response, but it still chews CPU until that completes.

Playground assistants page is definitely suffering from this issues. At least with Firefox. Didn’t notice the issue in Chrome.

  1. The main solution I got is to create a new chat session every time the memory usage of tab exceeds 800MB or when your browser/PC starts to lag.

  2. Try to edit your prompts if the output of model is not what you want instead of adding new messages in the conversation history.

  3. Try to provide precise and shorter prompts if possible.

Basically keep the conversation history as short as possible.

1 Like

Looks great and I have been doing the same. Still, it is an essential ‘distress’ for million’s users who are loyal to the AI applications if Open AI built in with something shouldn’t be from time to time.

I can confirm it is still not fixed. I just had to kill a web worker that was using 280% of the CPU :roll_eyes:

I’m using Brave Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (x86_64) on macOS Sonoma 14.1.2 (23B92)

Yeah been experiencing this alot in my Opera web browser with chatgpt. Also responses are awfully slow. For important work, I have resorted to using OpenAI GPT4 API via my selfhosted application using Big-AGI app racking a lot of charges on GPT4 API billable!