GPTs has no access to analyse my document, GPT 4 can

Hi,
I’m building my own GPTs, so I give some knowledges to my GPTs.

I give some book as a knowledge, in pdf version. I can upload it nicely. But when I ask my GPTs to find some information about one keyword, he can’t find anything and give me only some “classic” definition that he already learned without knowledge I gave him.

So I try to give this document as attask file to GPT4 and he fiund everything I need, has no issue, can be accurate with what I ask…

So I tried different file format on my GPTs → epub, zip, nothing work. (even when i ask him to priorly learn the document (he says he made this, learn this, open my zip and learn each things in this file),
but when i want to have an accurate information from this document (same word as before “simcoe”), it doesn’t work.
Only on Chat GPT4 it works… (pdf or epub it works)

Is there some people with these issues or do you have some advices to give me ? ^^

Thanks

Hi, when i started with my gpt i had same issues.

You need always to search in your knowledge?

For me it worked giving a prompt instruction saying something like “answer always using your knowledge document”

By the way, be careful:

  • knowledge searching is not always performing.
  • i experienced better performance using .md format, so i converted all my pdfs.

BRs.

1 Like