ERROR in read_any_format validator: while trying to use openai tools fine_tunes.prepare_data


I am trying to fine tune my dataset. My csv has two columns prompt and completion as described in the instructions.

I am using following command to prepare the dateset into JSONL format but I get the error

!openai tools fine_tunes.prepare_data -f ‘C:/Users/Zain/Desktop/PythonProjects/Gpt-3_mental_health_chatbot/data/Mental_Health_FAQ_Modified.csv’

ERROR in read_any_format validator: File ‘C:/Users/Zain/Desktop/PythonProjects/Gpt-3_mental_health_chatbot/data/Mental_Health_FAQ_Modified.csv’ does not exist.

However, I have the file in this exact folder. I have confirmed it by copying the path from Error and pasting it into my folder and it opens the folder correctly

1 Like

Any luck yet?

Is the csv file valid?

It’s a silly mistake. Just erase the ’ ’ at the beggining and the end and it’s solved. Took me hours to realize the error. Begginers mistakes I guess haha.


Thanks for sharing. Hopefully someone will see this and it will help them.


I’m getting the same error, I’m providing jsonl file as training data file.
any suggestions?

I was training with a .JSON file and I was getting the error, I was able to solve it by going from .JSON to .JSONL and everything was fine.