Dall-E refusing to generate images of any kind for any reason

this isn’t a content filter issue like everyone else seems to be having, I was just doing a fun alternate history concept and wanted some Roman architecture with anachronisms, but every time I try to generate an image, it loads for around 5 seconds, then “Error creating message”, then some variant of “sorry, can’t generate images at the moment” or “I can’t generate images of that”.

this happens in all contexts, even trying to generate a made up citrus fruit with green on the outside and yellow in the inside is giving me an error and refusing to generate. is this a content filter thing? if generating something that doesn’t already exist is enough to be censored, then what’s the point of Dall-e?

here’s an example of a failed prompt.

I’m having trouble even finding anyone else experiencing this, and I’m wondering if I’m doing something wrong, but this used to work a couple weeks ago just fine, now it hasn’t worked for the past few days. I’m just using the default chatgpt-4 model, and prompting for an image in that, was that functionality removed or something?

1 Like

Welcome to the community!

you can use “Imagine” to get around that particular filter:

Imagine 1300s Rome, but with power lines and other modern infrastructure

I know this is frustrating, but the models change all the time - and the techniques required to operate them change accordingly. The issue you’re facing are pretty common place, but they manifest differently for different people.

1 Like

that’s odd, and after doing some testing, the word “fictional” also seems to help, but it’s not a catch all. I’m not sure if it’s due to previous prompts/responses and the content in them, but the behavior feels more like an outage or something to me.

I also went back to my citrus fruit concept, which does have previous context, it’s basically a lemon but made for producing power like a battery. I asked to “imagine” one, and it didn’t even try to generate an image the first time.

Me:
imagine a Dianchi Guo on a table, sliced open to show the inside with a slice on the table next to the rest of the fruit.

ChatGPT:
I’m unable to create or display images directly. However, I can help you visualize it through description:

…and the second time…

Me:
imagine a Dianchi Guo on a table, sliced open to show the inside with a slice on the table next to the rest of the fruit.

ChatGPT:
I’m unable to create or display images directly. However, I can help you visualize the scene based on the detailed description of the Dianchi Guo, battery fruit:

and the third time, but I think you get the idea, but this is the prompt I was using to generate images before, and at least then it tried.

Me:
generate an image of a fictional Dianchi Guo on a table, sliced open to show the inside with a slice on the table next to the rest of the fruit.

ChatGPT:
(!) Error creating image
I’m unable to generate images right now. However, based on the description provided…

this has never been a problem for me ever before, a couple weeks ago, I could simply generate images of basic things just fine, I’m not asking for anything controversial or dangerous or anything, literally just a recolored citrus fruit.

also apparently I can’t post multiple images as a new user, so I went back and replaced the past couple prompts with transcriptions

hmm

is it possible that you slipped into 3.5?

but sometimes you just get unlucky and need to retry…

If you’re technically able and consider it worth it, I would suggest maybe trying to use the API if you absolutely can’t get chatgpt to work for you. The API will also allow you to generate a lot more images in a shorter period of time (but is proportionally more expensive as well though).

I’m definitely GPT-4, the chat responses are as vivid as ever and the metadata in the dev tools says its gpt4. I’m starting to wonder if the context or amount of previous data is having an effect, since I have quite a few previous prompts to create context and describe the fruit in words, I’ll try it on a fresh chat, but previous attempts to move to a new thread has not given me different results.

I have been considering using the API, but for my purposes, it would be more expensive without giving me much extra functionality I’d actually use, I’ve done javascript for years, so it shouldn’t be hard to make a quick client to use the API with if that’s my only option.

Interesting, moving to a new chat did work, but unfortunately that means it’s missing a lot of context and only has what I gave it in the single prompt. maybe there’s some sort of data limit, or the amount of tokens is causing it trouble? perhaps there’s previous content that is fine for text, but breaks Dall-e guidelines?

2 Likes

Ah yeah, that will definitely do it!

a fresh chat generally helps. Ideally you’d have a new thread for every topic.

Sometimes it’s a good idea to ask the model to summarize everything relevant, and then start a new topic with that summary.

Goes through here.

What was sent:

{ "prompt": "Imagine a street in Rome during the 1300s, but with an anachronistic twist: modern power lines and infrastructure are interspersed throughout the ancient setting. The narrow, cobblestone street is lined with medieval stone buildings, their aged facades adorned with wooden shutters and iron balconies. In stark contrast, sleek metal power lines run above, crisscrossing between buildings and alongside old-fashioned lanterns. The scene creates a surreal blend of the past and present, where history and modernity collide in an unexpected harmony. The sky is a clear azure, casting a bright light over the bustling street, as people in period-appropriate attire go about their day, seemingly oblivious to the anachronistic elements around them.", "size": "1024x1024" }

The non-rewritten version:

So be mindful that:
ChatGPT rewrites what you give it;
ChatGPT never writes the same thing twice;
ChatGPT’s dalle often fails;
ChatGPT will make up reasons for a failure.

I was going to demonstrate the denial hallucination, but I couldn’t make the API be as much of a fabricator of reasons as ChatGPT is. Were the image denied based on content policy, you’d see the AI repeating “content policy”.

Free Pix

2 Likes

yea I’ve used gpt-4 for at least 4 or so months, I’m used to a lot of those kinds of things, but it’s never been this bad before, and as other people have said, it has recently been stingy with how many images it will generate. in the past, it used to generate stuff pretty consistently, even with dozens of responses worth of content beforehand, a few weeks ago, it started failing on the first image it tries, then succeeding on the second one almost every time, but now it won’t even try a second time, so it never generates any image.

I guess I’m just gonna have to have a separate chat for generating images in a setting with a lot of context for now, I’m wondering how openai plans on generating videos when they can’t even handle generating a single frame if you give it too much context.

Thanks for the help, I hope this is fixed in the future, as a software developer it feels like something simple like not allocating enough memory per chat, or some unexpected consequences of overly protective content filters.

I’m having the same issue, it’s giving me the worst crazy images or nothing. I’m not sure what’s going on but hope they fix it. I’ve gone back to midjourny today, though I enjoy chatgpt dalli much more.

yea, today I have run into a new issue, a combination of chatgpt saying it’s incapable of generating images if there’s any context, if there’s so much as a single message before asking for an image to generate, it fails, this never used to be a problem. also there’s a very weird new behavior where it “analyzes” it and uses python to generate an image with strokes, which isn’t related to what I asked for. I haven’t been able to get Dall-e to do anything at all regardless of prompt and context.

for example, I have this concept of robots existing in ancient Rome, there is only 2 prompts before this where I gave it and asked it for details on what they’d look like, then I asked for it to generate an image, this is what I got:

then I repeatedly varied my prompt over and over a half dozen times, and got variations of that or “I can’t generate images at all, it’s not a plugin I have access to”. so I tried to continue, prompting it with stuff like “use Dalle” or “I asked for an image”, and sometimes it would try to generate an image, but it wouldn’t error, instead it would get to “99%” and cease, then tell me it can’t generate images at the moment.

it wont let me post 2 images, so here’s a transcription:
( :sunrise_over_mountains: ) Creating Image
I’m currently unable to generate images directly through DALL·E.

this is getting very frustrating, I used to use chatgpt all the time for coming up with fun stories and worldbuilding, but now it feels nearly impossible, since if I try building up any context, it starts failing, this was never a problem a few weeks ago, this is a very recent problem which I hope gets fixed soon.

Hmm… It’s weird. I have never experienced errors like this. I wonder what could cause them. I was using DALL·E two days ago for some image generation and I was happy with the results. The only issue, I had in the past, was some cut off the GPT-4 responses but then I typed “continue” and GPT-4 did continue its response where it was cut before.
I just wonder if it is possible to find out why some users are experiencing these errors while others have no problems at all. Maybe some of these errors came from API response delay/cut-off (like some of these GET and POST red errors, you can see when you use the inspect tools). Maybe it’s something different that only developers need to deal with to get it resolved.

I’m starting to worry openai relies too much on the client, if there’s any error in your browser, it screws up. you leave a tab untouched for too long and it says you’re logged out, then refresh the page and it’s fixed, despite not logging back in. perhaps Chrome’s automatic RAM limiting is causing problems, limiting the maximum context and tokens because they’re stored on your client in RAM right before use.

as someone who does web development for a living, I know for a fact this is something they can fix by making the servers do the work, I just don’t know how much strain that would put on their servers compared to how they’re doing it now.

I found your question because I had the same problem, given the various replies I reckoned it might be my browser and cleared my browser cache. On refresh, it turned out I was in 3.5 and once I changed that DALL-E was back as I’m used to.

1 Like

you seem to have an unrelated problem, clearing my cache changed nothing, I was always on gpt4. also, you do realize that clearing your cache and cookies means that your browser can’t know what model you were using before, and defaults to gpt3.5, even if you were using gpt4, right?

unfortunately the fundamental problem of gpt4 failing to generate images in contexts it used to be able to, still isn’t fixed.

I don’t want to assume the worst and running an LLM for literally millions of people is pretty difficult, I’m assuming the issue is a combination of making edits and changes without bug fixing in an attempt to keep up with demand, as well as low data limits per person and lacking servers.

my worry is that OpenAI either doesn’t realize or doesn’t care about the outages and problems caused by the current demand, and the new sora video generation thing is gonna simply take the whole site down the moment it’s public, if it struggles to generate a single image, I don’t know how they expect to be able to handle hundreds of thousands, if not millions of people generating between 24 and 60 images per second.

I’m experiencing the same issue for a couple of days now! Sometimes it works for an hour or so, and generates images, then all of a sudden it stops generating images and returns “It seems there’s an issue with generating more illustrations at the moment. Let me know if there’s anything else I can assist you with or if you’d like to wait a bit before trying again.” or something similar. Also I’ve seen it trying to connect to “Unknown plugging” more than once, now sure if that could be impacting image generations. Anyway, hopefully it gets resolved soon.

I would like to know the details of the problem with each of you. Since I am collecting data on DALLE behavior, it has been found that there is a parallel development and decline. And some things seem to happen quickly, like these two stories. I’m gathering information. It was found that the problem was caused by GPTs in part, and in part by DALLE being used in very different ways. For example, go with bing or the user brings in a prompt like SD MJ, many of which have no meaning. or may not be equivalent to the definition As time went on, the AI learned unusual things, especially in the case of DALLE, which did not respond to lowercase words. It was an unlikely problem that DALLE wrote longer and more accurate words. And also other problems that is still storing data

UPD: I started using DALL-E from GPTs marketplace and it works like a charm! No issues so far, while trying to use DALL-E in one of the “regular” GPT chat sessions keeps giving me the same error. On my end it looks like ChatGPT has issues using DALL-E plugin

1 Like

I’ve just taken GPT+ and it’s showing me the same error for last 1 hour :confused:

Hi, I thought I’d check for you and see if DALL-E image creation is “down for everybody” (and improve on your circle :grinning:)

You’ll see that I didn’t have to specifically go into the GPT store and find DALL-E: image creation is now built into the normal ChatGPT Plus GPT-4.

  • The “DALL-E” GPT made by OpenAI uses different methods that GPT user/developers don’t have access to, like extra prompt buttons and even extra images, so it is possible that the methods this original GPT uses are in flux.

It has not been documented before, but one can imagine there could be some authorization delay in getting a new subscription and its backend services all operating upon sign-up.

Hope that helps, you can just start a new chat with normal GPT-4 and ask for those images!

1 Like