DALL-E images downloading as WebP

OpenAI should really understand that changing the specifications of something that worked perfectly and nobody complained on a whim can lead to situations like this…

Step 1: find a figurine someone made of the character from a book
Step 2: have ChatGPT use computer vision to describe it
Step 3: have ChatGPT write a description as a photo of a real person
Step 3a: (have ChatGPT emit the dall-e call to the user instead of sending function)
Step 4: specify dalle tall, and paste the AI’s prompt again
Step 5: receive image in vibrant WEBP format at 1/10th the the file size of a prior PNG.

Amethyst, Princess

I too get the webp format. This morning I was able to ask it to provide me a link to download a high res PNG and that was working. Now that just ends in a “file not found”. Seems like kind of basic functionality for something that’s purpose built to generate images.

Just got the answer and seem not happy after read this

anyway they give a information
refer to this link for further information about the updates.

I cannot actually believe (but can actually believe) that outsourced tech support (I hope) would have a paste answer telling people to rename file extensions as a “solution”. Likely written without any info from OpenAI. So dumb.

You can see it’s an AI-created answer from the initially-identical completion starting, but my run will actually diverge at providing the correct answer with GPT-4.

(completion like this is just one more thing broken in GPT-4-turbo models, so it took more prompting of a user input asking for the response to be written, that also says “If output is incomplete, continue writing where you left off like a completion model.”.)

gpt-4-turbo:

right-click on the image, and select “Open with” followed by a photo viewer or editor that supports WebP format, such as Microsoft Photos, Adobe Photoshop, or GIMP. Once opened, you can then save or export the image in PNG or JPEG format through the application’s “Save As” or “Export” feature. This extra step allows you to convert the WebP file into a more preferred format without significant loss of quality.

We understand that this change might require an adjustment in your workflow, and we appreciate your understanding and flexibility. Our team is continuously working to improve our services and the user experience, and we take your feedback seriously. If there’s a significant demand for direct PNG or JPEG downloads, we will certainly consider reinstating those options or providing built-in conversion tools in the future.

Thank you for your continued support. Please do not hesitate to reach out if you have any more questions, concerns, or feedback.

Best regards,

(ChatGPT could have been helped be dumber with “browse with Bing” returning two wrong answer from the thread above…)

2 Likes

I really hope this will be fixed soon
!

Haven’t you read the their answer above? Nothing will be fixed because according to them, nothing is broken and this was done on purpose.

2 Likes

Unfortunately, the format change from PNG to WEBP is likely due to the adoption of a watermarking technology called C2PA, which is used to identify AI-generated images.

In this case, it is unlikely that they will revert the image format.

4 Likes

YOu can ask gpt to convert the file to .png. Problem solved. Why are you crying here about that for so long?

If you explicitly request to convert from WEBP to PNG format, it seems that it will use the code interpreter and perform the conversion with its functionality.

Simply saying “convert it to PNG format” might result in a response like “it’s already in PNG format.”

1 Like

I am not happy about this change to .webp, but I have found a way handle them without adding a ton of extra work. So for me, if I use the download button like I always used to, I cannot view the images anywhere- not in the Photos app, nor in any browser that supports .webp. I can’t rename the extension or convert them to a viewable image. What I am doing now is right click the image and save image as instead of using the download button. From there two different things work for me. For one, if I just save those as webp, they are viewable. I can also change the name to .png instead of webp and it then downloads as a png.

Does anyone else have a problem with downloading WEBP images? Like, every fifth or so image isn’t downloading correctly. It’s basically an “empty” image. Don’t know how to describe it. But no thumbnail, can’t be opened with any program…using a browser WEBP to PNG converter I get this message when I try to open these images: “Error: Incorrect type of file.
File type: text/plain”
Does anyone know what is causing this and can’t it be fixed?

1 Like

Adding .png at the end isn’t actually converting them to png. They are still webp images

The images themselves seem to have URLs that expire quite quickly after you generate an image or reload a chat. A conversation left open will have images that are not found with the download button. This can even affect scrolling back to see what was previously generated after the contents load but expire.

A conversation switch and reload or a browser refresh can then be necessary.

3 Likes

It’s happening with me with every image unless I do what I said in my previous comment- right click the image and save-as from within Dall-e. So don’t press the download button, just right click and save as, and change it to a .PNG there. Hope it works for you. It’s working flawlessly for me.

1 Like

I am furious that all images in CHATGPT 4 with DALLE are in webp format instead of png. I pay for CHATGPT Plus subscription £20 monthly specifically because of the image generation capability with stories which used to be good quality and in png format. Now the quality of image generation is appalling, not accurate and trust has definitely been lost with subscription holders. The images generated are useless, poor quality and are no longer worth the cost of the subscription. Aside from the image generations suddenly now only being in webp format (which CHAT GPT4 says is now a default setting it cannot alter) all images are poor resolution, inaccurate, do not follow prompts well and there are noticable anatomical errors such as extra feet and hands appearing. It’s like they wiped out the progress from the last 18 months and went back to poor quality images and incompetent capabilities. CHATGPT is now useless for images

2 Likes

You are incorrect. CHATGPT refuses this request. GPT gives a standard response stating it cannot provide images in png format and can not change the default which is currently webp format. It will NOT convert webp to png and it will NOT create images as png. I use GPT4 plus. Same thing in 3.5.

1 Like

I use Plus all the time. Is it possible that there are different options for us? I think no. Wanted to share my chat link, but it says it’s “Sharing conversations with images is not yet supported” So please here is just a screenshot. Also, you can create custom GPT, adding specific instructions to provide download link for every image crafted with .png

1 Like

Dont’ forget - you can also build custom GPT based on your needs. Train GPT to provide images and link for .png at the same time and that’s it!

1 Like

This is an atrocious functionality bait and switch. Unethical downgrade in functionality. The majority of users who would seek to utilize text-to-image in this way will not want to either pay for substandard Webp format NOR will they want to jump through all the tech hoops to convert. Crappy move that they did not have the guts to announce prior to enacting. I teach AI at secondary and post-secondary levels at several institutions. This dodgy maneuver is now going to be a case study.

1 Like