Custom GPT not following the OpenAPI Actions Schema

I created a custom GPT using the GPT builder. In Actions, I added the OpenAPI schema. The Custom GPT worked fine for a while, it called the correct API endpoints and showed the proper responses. After I added 1 or 2 more endpoints (Azure functions) it started to not call the correct endpoints. For instance, instead of calling something like GetUsers (which would translate to something like HTTP GET /GetUsers) it calls something like HTTP GET /status-0123456789abcdef (for every action I ask him to make). Now, as you might guess, it’s a random generated string “01234…etc”, so it seems to me that the Custom GPT doesn’t follow the OpenAPI schema. Anyone had this problem before? I have no idea how to solve this. My API has like 10 functions/endpoints (so it’s not that large). Maybe split the API in different Actions?

where you able to solve this by any chance? I’m experiencing the same thing except I only have one endpoint and it’s not respecting my openapi request body schema.

Worked fine for the first few times then it suddenly started using random keys and objects and arrays.