Custom GPT isn't accessing information in text files?

Hi there,

I’m creating a GPT that about to respond to users about public facing court cases. All the cases came to 100+MBs for the batch I’m testing, so I converted them to a text file and then split it in 5 parts.

After uploading the text files, the GPT is having a hard time returning information about the cases. It will error:

“There was an error generating a response”

What am I doing wrong here?

1 Like

“.txt” is not supported in GPTs file upload.

It is allowed.

Sometimes the system ''just" does not work.

Try it again and it works.

1 Like

So, it gives me a response a bit more consistently. But when I ask it a follow-up question, it errors out with Message in conversation not found. Not sure that the deal is.

Sorry to hear that.

As a test I did upload a plain textfile with not so much data.

Let’s say 250 lines of text about a specific subject, let’s say rocket science.

In the custom instructions I told the GPT that he was not allowed to browse the web or consult his “general knowledge”. He was only allowed to get his knowledge from the specific data in the textfile in his knowledge database.

Than I asked a question about something I was 100% sure it was written in that textfile.

Let’s say how fast can a rocket goes (you can even enter fake data to see if he really fetches the data from that file and not “illegally” from another source).

All my test were showing he was really reading the textfile (he also stated consulting my knowledge or something like that) and he did gave the correct answers all the time.

Best is to start with a new, empty GPT. No actions, no API, no high-end stuff; just an empty GPT and a single, easy to to read plain textfile.


No problem at all, and thanks for the kind reply. I think the issue is that the text file far too much text. The original pdf was over 100 mb in size. I converted it to a text file, then split it into 5 parts. But no dice.

I think I may have to abandon it, since it needs all the text to function the way I want it to. Or maybe remove the information from knowledge and turn it into something else. Sigh.

Though, the playground assistant didn’t have that issue.

I managed to upload 250.000 articles, worth of 500mb text data.

But the only way it was accepted was in a Excel sheet.

It worked, but sloooooooooooooow.

So I deleted the knowledge and did not try to recreate it.

1 Like

Just had one user say they received a 2 million max token message from the assistants API, not sure if the same limit is true with GPTs or even if that message was actually from the assistants upload system, but worth checking.

Yeah, I think I’ll have to do that then. Will probably have to do something custom with the playground assistant to do the heavy lifting.

Thanks for all the help on this Foo.

Hey, did it actually adjust how it responded to you as a result?

I tried to upload and excel sheet, and it basically refuses to read it or update its answers accordingly.

I gave up on it really. It can’t seem to handle things over a certain number of text. How much? No clue.

I used a pdf, and a text file. Nothing worked well. I’ll wait until its improved.

1 Like

This problem has started reoccurring now.