Codex js sandbox: refused to connect

while trying to call an API shows this error

1 Like

@salman0ansari, I believe that running the generated code outside of the sandbox might help you.

2 Likes

I think that’s a second option

I tried it and had the same issue. I exported to jsfidle and copy pasted it into an bitcoin.html.

2 Likes

In this case its Coindesk(dot)com. Maybe that is the reason it is not working in the sandbox. In the image of the error it also mentions issues with jQuery.

2 Likes

Coinbase API is a public access, innit. And they have scaled pretty good since 2017.

2 Likes

I have try many APIs nothing works shows same Error
Idk what’s wrong with playground but everything works fine in Jsfiddle.

This is happing with every public/private API I use.

1 Like

This thing is completely ruining my experience,
the API is 100% free requires no auth/apiKey still same error Link to API

Hi folks!

Unfortunately the sandbox currently doesn’t allow calls out to arbitrary APIs for security reasons. We’re looking into a secure way to offer this capability, but it might take a little while. In the meantime, you can export the code to JSFiddle or copy and paste the code into your own webpage. We’ll also try to make this limitation clearer in the UI to avoid confusion.

4 Likes