ChatGPT's first message Edit button and edited conversation gone (restored Sept 13)

It seems that I am no longer able to edit my prompts on ChatGPT (though I only checked on my phone so far as I’m currently away from my computer).

Am I the only one who’s dealing with this? If not, is it intentional?

4 Likes

In a simulated mobile aspect ratio and px, the very first message’s edit does not appear. The top model selection and share bar does not hide, possibly hiding the icon.
In contrast to a wide aspect ratio, the other edit buttons always show instead of needing to be discovered by randomly hovering in the right spot.

Then I discover that in a normal web browser, the same thing - the first message cannot be edited. The share bar has a slightly different behavior, not covering part of the first message, a previous annoyance I reported.

This screenshot is the second refinement of the message to change the question, but the scroll is not showing. Confirmed on the first message of other multi-thread chats, you cannot access the other revisions of prompts. I’ve essentially lost access to dozens of chats because I cannot see the first message’s variation selection < 1 / 5 >.

Did they decide that editing the first post makes it too easy to refine ChatGPT to act like you want? Or just bad code?

(this Discourse forum also is informed by the user agent to do dumb things)

Maybe someone thought that one sidebar conversation potentially holding a half-dozen separate conversation variations was far too convenient a usage pattern

…and then didn’t consider the loss of access to that prior chat data.

The icon is missing for me on desktop as well. I use Chrome.

Try Opera GX browser, the edit bar is visible.

2 Likes

Bro I’m on iPad how do I get opera gx on this

I did some tampermonkey on the page, brought the chat selector back to the first post, but it is < 1 / 1 > for a conversation that should have five variants.

There’s no edit button element on the first message served at all.

Same on Edge.

Looks like a “we meant to do that”. SOL.

Export under settings → data controls for a jumbled mess of your inaccessible chats.

1 Like

Just downloaded Opera GX, and I’m still not seeing edit icon on the first post, and I can’t go through previously edited prompts.

I guess it’s not a huge deal, since I can just use “Hi” as my first prompt, and carry on editing as usual with the second prompt. Still, if it’s deliberate, it’s a terrible decision.

Edit: The Edit option is appearing again, but only for the most recent conversation (on any browser). Older prompts can’t be edited, and even simply refreshing the page prevents further editing. You also won’t be able to browse your previous edits after you move away from the conversation.

It’s been fixed (or put back amid outcry). :speaking_head:

CTRL + refresh your browser to load new code.

However recalling old chat variations still doesn’t work.

1 Like

The previous prompts from the beginning is still MISSING…
OMG WHATS GOING ON???
MANY OF MY GENERATED CODE CANNOT SEE AGAIN!!!
IT RUINS MY JOBS!!! !!!

1 Like

You are correct, problems continue even though it is re-enabled for new chats.

In a browser tab that I’ve had running continuously without refresh, old conversations can be recalled by the toggle between conversation threads.

In a new and refreshed window, past variations of chats are still inaccessible.

1 Like

It’s still exactly like what I said in my previous post, so not fixed.

Also, from the time this started happening, ChatGPT has been struggling to come up with appropriate titles for my conversations, often giving me nonsensical ones that are completely unrelated to my requests.

I had some important generations saved on my ChatGPT account.

Now when I go back to a specific conversation, I can’t see the “Edit” button, nor the arrow buttons (which I need to access the generations I’m looking for).

Is this a permanent update and my content is lost? or is it a temporary bug?

NB: I’m a Plus user using both GPT-3.5 and GPT-4.

Your question has been moved to where others see the same issue.

There was a small improvement, but we hope they will fix it completely to get all the old conversations back.

There’s three things to note here with all these strange occurrences.

  1. The interface, and the backend are being updated constantly without any transparency or true changelogs.

  2. These strange issues occurred at the same time (I believe).

  3. There are most likely other issues that we aren’t aware of

As soon as this edit issue occurred I was compelled to investigate. Strange things are fun. It was not a css issue, but more of a rendering issue. As noted previously the edit button did appear for only a moment before a network connection was made (which is indicated by the share link appearing and cGPT responding).

By throttling the network I was able to catch the edit, and send it in (indicating a front-end issue). The interesting thing I found was that the edit successfully sent but the history was not acknowledged. I had no way to go back even though I just made the edit.

So two thoughts:

  1. They prematurely implemented some new change to prevent first post edits (wouldn’t be surprised)
  2. They had made some changes (such as a rollback) and were not correctly identifying the first post

I quickly noticed the following: Sometime after July 30th they have been prepending an “unknown” field to messages. Just for reference Custom Instructions came out July 20th. I say July 30th because I just so happened to have screenshot the components on that day for a different reason as seen here (ignore the red circle)

In this screenshot on July 30th it is clear that the user has the EVEN keys (starting from 0) and the model gets ODD keys. So each conversation should end ODD as the model always is the last response. Again, this was already when custom instruction was released.

I also took a screenshot when all of this weird shit was going on. Notice something different?

There is a “ghost” component being prepended with no information. AGAIN. CUSTOM INSTRUCTIONS ALREADY EXISTED. Also, I tested this with custom instructions on and off with no change.

Then, finally, the edit button reappeared. Look at what they did now.

Screenshot from 2023-09-10 14-34-28

Yes, they hacked a solution by prepending ANOTHER ghost component (indicated by no arrow)

Why would it only be the first comment that was affected? No idea. But the fact that the “fix” was to prepend a second phantom element makes me think that #2 is more likely.

It seems to me the reason the edit button appears only momentarily is because once the conversation is realized & sent back it, is sent with the phantom component causing the edit and history sub-components to vanish.

It seems to me that for whatever reason they rolled back certain parts of ChatGPT. My best guess is that this initial “unknown/ghost” component IS their code not correctly parsing and popping the custom instructions. Resulting in an “unknown” role and empty content. Then again with these very weird titles to me it seems like some miscommunication.

I’m sorry for being late to the party. I was doing some kinky shit for a week. PS If I never post again I have gone on a lifetime vacation so pour one out for me if it be like this.

2 Likes

I am reporting this error. The support replied to me like this:


Hi there,

Sorry for the trouble! Without more information, it’s hard to tell for sure, but this could either be a temporary glitch on our end or an issue with how your computer is connecting to our services.

As a first step, it’s important to try using an incognito browser window, a different browser or computer, or a different network. It’s possible that a browser extension is causing issues, especially if you instaled an extension to add functionality to ChatGPT.

If you’re encountering this problem intermittently, we recommend checking our status page ( when you get an error like this to see if we’re already aware and fixing it. Although we’re continuously making our services more reliable, our servers may experience intermittent errors during particularly high traffic.

In most cases, you can simply wait a few minutes and try again. If you’re still running into problems, it’d help if you can try these steps first to help us figure out what might be going on:

  1. Try clearing your browser’s cache and cookies
  2. Disable VPN (If you are using one)
  3. Use an incognito browser or a different internet browser/computer to see if the issue still persists, as a security add-on or extension can occasionally cause this type of error.
  4. Disable cookie blockers
  5. Try connecting to another network

If none of that worked, could you send us more information about the steps you took leading up to the error (such as anything you clicked on), as well as details about what happened when you tried the steps above? More info about the error message itself is helpful too, especially specific wording or a screenshot. We’ll take a look and do what we can to fix it with you.

  • OpenAI Team

This means that everything works great, there are no errors and they haven’t made any changes.
And I still don’t have access to previously saved chats, which interferes with my work :frowning:

You got robot-replied with scripted uselessness.

It is a universally-experienced change in the software affecting everyone who has used the feature in the past. Past variations are left inaccessible. Usage pattern of the re-emergence has forced alterations.

Current use of the edit on the first message also only allows you to essentially create a new conversation - the earlier variant has been spawned off as a different conversation in the history but with the same title.

The inferred specification that must have come down: “stop letting people usefully have multiple conversations per sidebar entry, and make this happen now!”; “We need to make the site so idiot-friendly that only idiots will use it”

(tampermonkey to force appearance of chat toggles gives no ability to recover old variations either. The newly-edited chat has a toggle of < 0 / 1 > while the original is < 1 / 1 > when this control is forced visible)

Yay, operation of ChatGPT is finally restored and past chats that branch from the first post can be recovered!

:woman_mechanic: :tada:

I am missing the edit option in the dropdown on desktop, all browser types. I hope it comes back soon!

Still there, after hard refresh.

If the browser window is wide, the button will be on the right side and hidden until you hover.

Have to agree to new unilateral terms of use and privacy policy to continue though.