Can't get openai python package working... please help!

Hi! I’m a novice developer but was excited to try working with the OpenAI API. However I can’t even get the package working (not a great sign haha).

My steps:

  1. I installed the openai package via pip3:

pip3 install openai

I received this message after installation in the terminal:

WARNING: The script openai is installed in ‘/Users/me/Library/Python/3.9/bin’ which is not on PATH. Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.

I followed ChatGPT’s instructions (haha) to add that into my path by the following:
> nano ~/.bash_profile

And entered this:

export PATH="/Users/me/Library/Python/3.9/bin:$PATH"

Saved that file and then tried:

openai --help

Which produced this:

/Library/Developer/CommandLineTools/usr/bin/python3: can’t open file ‘/Users/me/Library/Python/3.9/lib/python/site-packages/openai/’: [Errno 2] No such file or directory

Interestingly I can use e.g.: pip3 show openai, which shows this:

Name: openai
Version: 1.12.0
Summary: The official Python library for the openai API
Author-email: OpenAI
Location: /Users/me/Library/Python/3.9/lib/python/site-packages
Requires: anyio, distro, httpx, pydantic, sniffio, tqdm, typing-extensions

Seeing this location in the show info, I also tried changing the PATH info to:

export PATH="/Users/me/Library/Python/3.9/lib/python/site-packages:$PATH"

But this didn’t work either.

I could really use some help getting this working!! Thank you so much.

These instructions are meant for Unix systems while your computer is clearly windows I’m dumb, this is Mac.

I know you’d prefer a simple “do this” answer but I highly recommend setting up a virutalenv. It’s very simple to setup and helps keep your code contained & easier for transport.

pip3 install virtualenv

virtualenv -p python3 ./my_openai_project

source my_openai_project/bin/activate

If you don’t care and would just prefer to figure out how to resolve the error just ask ChatGPT to repeat the instructions but this time for Windows.

1 Like

Sorry I should have said; I’m on a Mac! Thanks

Ah, sorry. Never used a Mac. Regardless the same information applies.

Hopefully you’ll get some help from another Mac user. I have no idea.

If you are trying to program using the client library I’d still recommend using virtualenv.

Digging deeper, I would say that your pip isn’t installing the packages to the correct spot.

Thanks again; ok. I have not had any issues with the numerous other packages I have intalled (maybe 7 so far?)… I don’t know what’s special about this one!

I’ll check out virtualenv. I vaguely remember using it years ago. All the best.

This is a typical issue when globally installing packages (environments get messed up, multiple versions are added) and everything starts to get mixed together.

I can’t think of much besides the obvious “reinstall it”, and “is it actually there?”, sorry I can’t provide anymore help.

Virtualenv is very easy to setup and it will save a lot of headaches

You have latest MacOS? AI writes answers for you:

  1. The default Python version bundled with the latest macOS (Sonoma 14) is no longer 2.7; it has been upgraded to Python 3.9.6. This change occurred starting from macOS Monterrey 12.3, where Python 2 was removed from macOS and only Python 3.x.x is available pre-installed.

  2. To check the version of Python you’re currently running within your code, you can use the following lines in your Python script:

    import sys

    This will print out the version of Python that your script is currently using.


To ensure that the OpenAI library is installed to the Python version that is in the OS path, you can follow a few recommended practices:

  1. Use the Python Version in OS Path: When installing packages with pip, it’s crucial to use the version of Python that is in your system’s PATH. This can be done by explicitly calling Python and pip using the -m flag, which ensures that you are using the module of the Python interpreter that you have in your PATH. For example:


python -m pip install openai

This command ensures that pip installs the OpenAI library to the Python version you are currently using in your terminal or command prompt… (more stuff about virtual environments follows from AI)

Also, this will be useful:

You can set the environment variable OPENAI_API_KEY to the one you generate. Then your openai client() doesn’t need this.

Hope that helps!

1 Like

For the record, I’m still running into this issue even when using a venv and trying the python -m pip install openai command.

Trying to bring this up with OpenAI support via the chat widget but so far just the AI is responding to me… Haha.

Have you tried to navigate to the folder both being thrown & also the path pip believes it’s installed?

You shouldn’t need to use the command openai. You would just import it in your code.

Regardless I can understand wanting to fix it. My first step would be manually validating the locations. My bet is that there some weird mixups happening (pretty common)

Once validating I would try to call it without using the path variable. Then something as simple as asking cGPT to spot the difference or to set it up.

I’ve never willingly used a Mac before, the folder path seems a lot like windows to me… Is that typical?

The typical “reinstall it” would also apply here. As in delete all instances of Python, & pip. Then retry fresh.

OpenAI “help” is not in the business of diagnosing OS installs or giving programming lessons.

You might find some Mac experts that can help you figure out how to get pip to install things into the current operating environment, or create your own modifiable python install all in user environment, with path set to point to it.

If you want to ask an AI, here’s a chatbot that requires no additional libraries (this example refactored from using requests library by AI)

import os, json, urllib.request, urllib.error

model = "gpt-3.5-turbo-0125"
system = [{"role": "system", "content": f"You are ChatBro, an expert AI assistant powered by {model}"}]
user = [{"role": "user", "name": "intro", "content": "Provide brief introduction."}]
chat = []
params_template = {"model": model, "max_tokens": 666, "top_p":0.9,}
headers = {"Content-Type": "application/json",
           "Authorization": f"Bearer {os.environ.get('OPENAI_API_KEY')}"}

while not user[0]['content'] == "exit":
    request = {**params_template, **{"messages": system + chat[-10:] + user}}
        req = urllib.request.Request("", \
          headers=headers, data=json.dumps(request).encode())
        response = urllib.request.urlopen(req)
    except urllib.error.HTTPError as e:
        print(f"HTTP error {e.code}: {}")
        user = [{"role": "user", "content": input("\nPrompt: ")}]
    except Exception as e:
        print(f"Error: {e}")
        response_body = json.loads(
        reply = response_body['choices'][0]['message']['content']
    chat += user + [{"role": "assistant", "content": reply}]
    user = [{"role": "user", "content": input("\nPrompt: ")}]

The API key environment variable is needed as described before – or you can just paste it right into the code instead of {os.environ.get('OPENAI_API_KEY')}

Can we please avoid regurgitating GPT solutions.