Azure Open AI Client not working with Threads

I tried using the AzureOpenAI instead of OpenAI from openai python latest library. It unfortunately fails on threads.create()

azure_client = AzureOpenAI(
    api_version = os.getenv("AZURE_OAI_VERSION"),
    azure_deployment = os.getenv("AZURE_OAI_DEPLOYMENT"),
    api_key = os.getenv("AZURE_OPENAI_KEY"),
    max_retries = 3
thread = azure_client.beta.threads.create()

How do I mitigate this issue?

Pushing this to the top of the board. Systems are down. When can we expect the threads to be support on the AzureOpenAI Client. The client is half way there.

It seems microsoft has not implemented the assistants and threads endpoints. cant find any information in the official documentation.

We need a solution to the same issue.No info in the documentation. If anyone solved this issue help me to solve it also.

There is no information on this from Microsoft end too. Can’t wait for the AWS guys to do something. MSFT and OpenAI aren’t helping the devs as such from what it seems. If you reach out to Microsoft, they put it on OpenAI, while here on OpenAI, it is hard to even solicit a response from their team.

Asking OpenAI about and Azure created library will be problematic, if you have an issue with the OpenAI library that yopu need help with, then there should be someone here who can help with that. Azure libs are handled by the Microsoft team and you will need to go through them.

I went the Microsoft route. However, since the openai-python repo is managed primarily by OAI, Microsoft declined to assist in this matter. So, my only bet was and is, the OpenAI dev team. I can only push as a business user but hoping for a faster resolution since Azure is where our credits and all our computation workloads are running at.

this is not a library issue. my understanding is that the /threads endpoint is not avaiable via azure… the question is why and who is in charge. we should not forget that openai has launched a enterprise plan and they are competing with microsoft for customers. we unfortunately have to wait or use openai directly which is not an option for our company because we need to have the data in europe…