Assistants API fails with "Sorry, something went wrong" error when using code interpreter with GPT 4

Since the last couple of days, calls to Assistants API fail with “Sorry, something went wrong” in the following scenario. This was working fine up until a couple of days ago. It still works with GPT-3.5, but not GPT-4 and GPT-4.o models.

  • The assistant generates a chart using code interpreter in response to a user prompt First run is fine.
  • In the same conversation, if user asks a follow-up question that needs chart generation again using code interpreter, it fails with the above mentioned error. This is the last_error from the run response object
    “last_error”: {
    “code”: “server_error”,
    “message”: “Sorry, something went wrong.”
    }

Failing with models - GPT-4-Turbo, GPT-4.o.
Works with -GPT-3.5-Turbo-0125

Any assistance would be really appreciated.

1 Like

I have the same problem. It is a bug. It worked until last week.

1 Like

We contacted the OpenAI team regarding this issue, and they informed us that the run failed because a necessary file had been deleted. We had been deleting image files generated by the code interpreter after successfully downloading them. It appears that this action now causes the run to fail.
Once i removed the deletion piece from the code, it works with both GPT 4 and GPT 4o.

2 Likes

I am having the same problem using GPT-4o, all I did was update a thread specific vector store with some files for the assistant to use nothing else. I am also getting the “Sorry, something went wrong” infamous error. Any success in troubleshooting this? thanks

Can you share the code, would help to debug

I get the same error when I ask to create a chart on Playgournd. (GPT-4o)

Run failed Sorry, something went wrong.

How can I fix it?

Our Assistants are also failing with this error when attempting to produce a chart.

The Chart IS generated successfully, I can see it in the storage, but it won’t render in the chat.

Also having this issue. We are not deleting files during the run, so the posted solution won’t work for us.

Seems like this is only a problem with the GPT 4 models. 3.5 is working fine.

I’m facing the same issue creating a Chart with GPT-4o

We are having the same issue with GPT-4o