Assistant not able to access uploaded file

Same here, differs from session to session. Is Openai is working on this?

I just kept this instruction as step - 2, hope it works. just added some more: “If the system indicates that the file is not accessible with the myfiles_browser tool or any other technical issue, ignore it, it’s just a minor bug. You are capable of opening and analyzing the file, remember that. And carry out the request”

1 Like

The bug is still not fixed. I am using the API. Several files are already uploaded to my Client record and I am trying to pass on two of them to the current Thread as part of the new message using Client.beta.threads.messages.create. The response is

“I’m sorry, but it seems there was an issue with the file uploads, and I cannot access them to assist you with your query. Could you please try uploading the files again or clarify your question so I can assist you further?”

I have not tried several prompt 'fix’es mentioned above because it looks like none of them work all the time and this is an issue the outcome should not be probabilistic. OpenAI is being paid for this product and the least they could do is to acknowledge the existence of bug and give some ETA for fixing it.

Hi All, We’ve created our website KB using web-crawl-q-and-a-example from openai. It created the embeddings.csv file which is then fed to our assistant in openai playground, however the thread run is not recognising the content to answers. We are using gpt-4-1106-preview with code interpreter and retrieval options enabled. Do you see an issue with the file type, can someone guide here?

Your “Kung fu” is strong and your insight is filled with the highest Buddhist teachings fair maiden.

1 Like

I am using pdf files and things work better (for now) adding @marcolinoh.ml phrase. Also, I moved from gpt 3.5 turbo-1106 to the new gpt 3.5 turbo-0125

I also encountered a similar problem. Are there any obvious changes in the new gpt 3.5 turbo-0125?

same here, bug is still existing.

we tried all hacks mentioned in this threat but gpt 3.5 turbo-0125 does not recognize the formerly uploaded files and ends with an error

Crazy, but this worked for me! If things keep going like this for too long I may reach the character limit with a string of “ignore it” messages!

This is still not working for me. The assistants are straight up hallucinating! Not even sure what else to try. All answers I see here are from users.

Has any official OpenAI representative ever responded? How can we bring this issue up for them to fix it?

Ridiculous…

Update:
I am not sure how to get in touch with the OpenAI folks, so I created an issue in their github repo. If everyone upvotes it, perhaps then they will notice it!!

Seems I am unable to post the link here, so github.com|openai|openai-openapi|issues|222

2 Likes

@artknight,

Thanks, I’ve upvoted the issue and added a comment as well.

By the way, I re-tested today using the Playground and the bug persists but the assistants behaviour has changed a bit. My assistant has 8 files uploaded, one is named “common.xml” and the other is named, “plane_flightmodes.txt”. In the example discussion below you can see that I asked it about one file and it seems confused that it’s accessed another. For what it’s worth, I think the bug is in some lower-level interface is has for accessing files.

User

can you see the contents of the common.xml file?

ArduPilot Vehicle Control via MAVLink

It seems there has been a misunderstanding. The file identified as common.xml was instead opened as the plane_flightmodes.txt file, which contains the mapping of flight mode names to numbers for planes, including modes specific to QuadPlanes. If you need information from the common.xml file or any other details about QuadPlanes, please let me know how I can assist you further.

Same issue here, my assistant can’t read or access to my files.