Assistant Api - Run Status Api call timeout issue

We have a working system which works as expected till yesterday, it started getting delay from yesterday. On debugging that, we came to know that the “RunStatus” api calls on a certian limit getting time out without getting any response, but after timeout, on calling the ‘GetMessages’ api, we are getting the message added as response for the Run command.

Is this something that was known issue on Open api side? Again this is working and issue started from yesterday without any new change on my side. Please suggest.

Note: After adding a message and running the thread, we are polling the checkstatus ever 200ms. So, this checkstatus call is causing issue occationally.


In my experience for Assistants the check can/should be 1second or more for a single run, that is assuming of course you’re not running a chatbat. I run a lot of background Assistants that also run in parallel.
The performance for Assistants varies widely and wildly in terms of time needed to finish. RPM does include status checks

1 Like

I always timeout too, but the message appears afterward. If the assistant writes a small message, everything is fine, but if it’s big, it times out

I am having this issue as well.

I use “Make” to automate some processes that are connected to an OpenAI Assistant API and since today the 5min timeout limit in Make is constantly reached, whereas for the past two months, the response time has been very quick and I got my replies within seconds…

Checking the OpenAI status indicates that there are no issues.

1 Like

Same here! Everything was fine up to yesterday and today it went crazy in completion time… no clue of why

I’m running the same issue on my serverles chatbot , 75% of times it hangs my serverles service has a not modifiable 10s timeout, some days ago was well working fast and stable, yesterday was a 25% fo timeouts but today is the oposite 75% or more of runs hangs over 20 or 30s

1 Like

Exact same issue here. No errors thrown, no result returned, it just stops pinging the API to retrieve the run after a while. Not sure how to deal with that :confused:

Same issue here. Woke up to many email complaints from users. Unfortunately, the Assistant API seems to be the red-headed step child. It could be down for days and the status updates would still show it’s operational.

We do use it daily and while there are big changes in performance we have had very few actual outages since we started using it in early December.

Same issue,

Today, it’s not even responding with anything, no message, no status update. Just takes the input, consumes tokens, and then disappears.

Tested it in the Assistant API test environment as well - the same behavior. However, the test environment does tell you how many tokens it consumed when it just quits. Don’t get that info reported back through API to my app though.

It started happening today. Worked fine before.