AI Assistant Want Users to Sign In (Trust) The App Before Messaging

Hello Everyone,

First of all, thank you for taking time with my issue. Even if it’ll be a dead end, I really appreciate it.

My issue that is with the Tumblr API. This is my first time using and doing something with the Tumblr API and I research and tried everything to solve it but I can’t manage to get it.

I made AI Assistant that the custom bot will browse the user-requested hashtags and reply to the user with images and post links with the instructions that I gave it to it. It’s very simple and basic.

Whenever I’m sending command to browse the hashtags, firstly it’s want me to sign with the Tumblr and trust it. The button redirecting to a blank page and does not have effect on it. You can see it below.

I adjusted all of my authentication on Tumblr and OpenAI. If you want to look at my Schema, that is main functionality to run the bot, here is it:

openapi: 3.1.0
info:
  title: Tumblr Posts Fetcher
  description: Retrieves Tumblr posts based on user-specified tags. This service does not require user registration or login to Tumblr.
  version: v1.0.0
servers:
  - url: https://api.tumblr.com
paths:
  /v2/tagged:
    get:
      description: Get posts for specific tags
      operationId: FetchTumblrPosts
      parameters:
        - name: tag
          in: query
          description: A tag or a list of tags to retrieve posts for
          required: true
          schema:
            type: string
        - name: limit
          in: query
          description: The number of results to return (optional)
          required: false
          schema:
            type: integer
        - name: before
          in: query
          description: Retrieve posts before this timestamp (optional)
          required: false
          schema:
            type: integer
      responses:
        '200':
          description: Successful response
          content:
            application/json:
              schema:
                $ref: '#/components/schemas/PostsResponse'
components:
  schemas:
    PostsResponse:
      type: object
      properties:
        response:
          type: array
          items:
            $ref: '#/components/schemas/Post'
    Post:
      type: object
      properties:
        id:
          type: string
        blog_name:
          type: string
        post_url:
          type: string
        type:
          type: string
        timestamp:
          type: integer
        tags:
          type: array
          items:
            type: string
        content:
          type: object

What am I doing wrong? Based on your questions, I can provide other settings that I did.

Thanks again!