A bunch of models removed from playground and api?

I noticed my assistant-powered chatbot is suddenly not working, and the error message indicated gpt-4o is not an available model. I check the playground and it seems like a bunch of models aren’t available? I am assuming this is a temporary bug?

edit: figured out the issue, it was due to permissions set within project only allowing certain models to be used.

1 Like

Thanks for flagging.

I just reviewed the playground and can confirm that all models are available on my end. However, if others are experiencing a similar problem, it would be useful to know.

1 Like

Interesting, I’d be curious whether anyone else is experiencing this too. I created a new project within my organization and in that project it appears all models are available as expected. But in the project which contains the vector store I need, I can’t select the model I need still.

Could it be that the assistant in question is on the V1 rather than V2? If so, your linked VS should also be free until next year, but you have real annotations!

No I actually just created this assistant a couple weeks ago, and it was functioning totally fine (using all the v2 file search functionality) until I tried to use it today. I tried modifying the assistant via api just now and got this error: BadRequestError: Error code: 400 - {‘error’: {‘message’: “The requested model ‘gpt-4o’ does not exist.”, ‘type’: ‘invalid_request_error’, ‘param’: ‘model’, ‘code’: ‘model_not_found’}}

So I cant seem to select most models via UI or API

I am realizing the only thing that I changed since it last worked was inviting someone to my organization as a new owner, can anyone think of why this might remove available models from a particular project within that organization, (but not all projects apparently)?

edit: ok I figured it out haha thanks everyone, it was due to changes made in the model usage limits section of the project, I was trying to block those gpt-4 models from being used but set it so only those ones can be used.

1 Like

Oh alright!, Actually didn’t know that could be limited by org, gotta look into it.

Good luck!