When calling the API, the model passed in is gpt-4-0314. When asked what language model it is, it still says that it is gpt-3. Why?

Can someone tell me why this is

When asking for things like this, never trust what the response of GPT is. See it said gpt-3 and not even gpt-3.5-turbo, which is the recent model. This is just the data that it has been trained on and will respond as such.

1 Like

Does that mean to look at the model of the response, if it is gpt-4-0314, it is gpt-4?Is this understanding correct?

I have done the same and I get back:

“I am an instance of ChatGPT, based on the GPT-4 architecture, which is a language model developed by OpenAI. These models learn patterns in human language and generate responses based on those patterns.”

Do you have access to the GPT-4 API? If not, it will default to gpt-3-turbo.

I disagree with what you are saying. The model is an entirely different model which it knows it’s own context by definition. If it had said GPT (without the version), then your point would be valid, but the response it is providing implies that it is massively misaligned if this is truly GPT 4.

Can anyone tell me if this is normal? If not how do I need to correct it?

I have the GPT-4 interface permission, I have applied for it and received an email from OPENAI to access it, but I still encounter this problem

Can you try and use the model “gpt-4” – I dont think you can use the model 0314 in the completions endpoint.

To use a GPT model via the OpenAI API, you’ll send a request containing the inputs and your API key, and receive a response containing the model’s output. Our latest models, gpt-4 and gpt-3.5-turbo, are accessed through the chat completions API endpoint. Currently, only the older legacy models are available via the completions API endpoint.

Newer models (2023–) gpt-4, gpt-3.5-turbo https://api.openai.com/v1/chat/completions
Older models (2020–2022) text-davinci-003, text-davinci-002, davinci, curie, babbage, ada https://api.openai.com/v1/completions

You can experiment with GPTs in the playground. If you’re not sure which model to use, then use gpt-4 or gpt-3.5-turbo.

Tried to access gpt-4 but the effect is still the same…

The response is showing the model you had previously sent. Can you try a new request rather than modifying the existing one?

Changed a new request, whether I request the model to write gpt-4 or gpt-4-0314, the returned model is gpt-4-0314

And I tried gpt-4 in the playground, and it seems to return gpt-3, which is the same as the result of my API request. Does it mean that @udm17 is right?

can you run;
GET https://api.openai.com/v1/models (with bearer token)

I am a bit curious to what led you to ask the model what language model it was? I am assuming the prompts you were given were not answering to the level you was expecting?

gpt-4-0314 is a snapshot of the gpt-4 model, as it were on 14/03/2023 when it was released. So yes, that would be correct

Model 0314 works with the completeion endpoint. I have been using it in my pipeline for a few weeks without any problems (except from some server side ones last week). The performance itself isn’t so bad as well

So if you want an accurate response you need to tell it what model it is as part of your prompt. Add this to your system message:

Model: GPT-4