What's the best way to avoid "training data slippage" in text generation with davinci-003?

With davinci-003, we get the impression that it has a tendency toward what I call “training data slippage”. Davinci-002 didn’t have that, at least not for our parameter settings.

Here’s what I mean by “training data slippage”:

When prompted “Tell me more about energy harvesting”, I get this response from davinci-003:

“Energy harvesting is the process of converting one type of energy into another type of energy. This can be done using a variety of technologies, such as solar energy harvesting, which converts sunlight into electricity, or piezoelectric energy harvesting, which converts mechanical energy into electricity. Energy harvesting is a growing field of research, with the goal of developing more efficient and sustainable ways of generating and storing energy. Learn more about energy harvesting at Wikipedia. Here is a video on energy harvesting: Energy Harvesting from Piezoelectricity Energy Harvesting from Solar Power Energy Harvesting from Mechanical Power Energy Harvesting from Waste Heat Energy Harvesting from Wind Power Energy Harvesting from Biomass Energy Harvesting from Tidal Power Energy Harvesting from Ocean Waves Energy Harvesting from Geothermal Heat Energy Harvesting from Hydropower Energy Harvesting from Nuclear Power Energy Harvesting from Fuel Cells Energy Harvesting from Biogas Energy Harvesting from Waste Gas Energy Harvesting from Landfill Gas Energy Harvesting from Biomass Gas”

The text starting from “Learn more about energy harvesting…” looks like it’s just Davinci-003’s training data slipping through.

Does anyone have a suggestion for how to best avoid this? For example, does anyone have experience which parameter settings tend to affect or control such behavior? “Presence penalty” for example?

Thank you very much for your help!

I’d increase the frequency penalty parameter first. The scope of this parameter is to reduce the probability of the model to use the same line verbatim.
If the model still outputs lots of repetitions, I’d also increase the presence penalty (this one increases the likelihood of the model to talk about new topics)

Great, thank you very much for your help! Will try this.

Are you using a high temperature?

Thank you for mentioning temperature. Yes, temperature was what I’d call high (0.7 - 0.9). But temperature doesn’t seem to have a strong effect. Ordered by how much it helps solve the problem, I’d say:

  • Frequency penalty
  • Temperature (seemed to have no effect really)
  • Presence penalty (this reduced repetitions, but increased “rambling”, so I’d say increasing presence penalty had more of a negative effect overall).

The above are just observations with a few dozen examples. But so far, that’s the impression I got.

Thank you again for your help, I appreciate it!

in my case Temperature and Frequency tend to add noise to the out equally.

if I increase temperature above 0.4 I get leading/trailing noise like \n\n\finish

If I add frequency even at 1 or 0 it adds noise.

Also it’s not consistent with temp=0.4 the noise occurance varies. So to handle this anomaly I am also send an additional instruction in the prompt: Start and end response with | - which seems to work for now