Unable to get API response inside VR headset with apk built with Unity

I’m building a Unity application in VR and I’m trying to integrate OpenAI to my existing project.
I tried integrating OpenAI API in a new VR project for testing and both Whisper and Chat API works.

But when I integrate OpenAI to my current project, when I call openai.CreateChatCompletion, it doesn’t give me any responses. Same goes with openai.CreateAudioTranscription which doesn’t give me any response from the await function.
The problem only occurs when I did the calls when I run directly on the headset with the VR application that I built through apk. With the same setup, everything works well on Unity Editor and I am able to get both responses without any problem.
I made sure that it’s using the exact same API key which I used on my test project which worked, and it’s hardcoded in new OpenAIApi declaration.

I tried various solutions like adding read/write permissions on AndroidManifest, as well as upgrading my Oculus Plugin, but none of them works.

For reference, my project is built using Unity 2019.4.22f1. And I have Playfab and Photon API calls integrated in my project.

What could have been the cause of the problem where I could not get any responses after integrating OpenAI to my project?