The model: `text-davinci-edit-001` does not exist


Since an hour or so I’m getting the error The model: text-davinci-edit-001 does not exist when using the Edit API as documented here: OpenAI API

Full response:

    "error": {
        "message": "The model: `text-davinci-edit-001` does not exist",
        "type": "invalid_request_error",
        "param": null,
        "code": "model_not_found"

Is this API deprecated and what is the replacement API/model/engine?

Thanks in advance!


I’m getting the exact same thing. My app stopped working due to this. Then when I looked at the logs, the chatgpt api was saying “Sorry, I am an AI language model and I do not have access to the transcript you are referring to.”, but when I ran the same exact prompt (with all the same settings) in the playground, it worked perfectly. Something is messed up with the API, even though the status is saying it’s working fine.

1 Like

Same here. Hopefully its just a temporary issue. Anyone here, who has an info?

Same here, but for me,
not only text-davinci-edit-001 but also code-davinci-edit-001 fails with the error.

I’m getting the same error today for both text-davinci-edit-001 and code-davinci-edit-001. It worked yesterday.

I don’t see text-davinci-edit-001 and code-davinci-edit-001 listed in the models API response.
Could it be related to this issue?

I mean yea, in the api, the model no longer exists. even in the playground I can select it, then it says the model no longer exists.

But it does list it in the documentation:

1 Like

I found this article: OpenAI to discontinue support for the Codex API | Hacker News

It seems related.

@meinside , Yea, I agree with you. I think it’s probably related. However, as per the article (and the email I received), the models effected are:

code-cushman:001 code-cushman:002 code-davinci:001 code-davinci:002

the edits model should not have been removed. I wonder if they either removed them by accident, or they forgot to mention that they were also going to be removed. I hope it’s the former, and they bring it back. I needed it for the my company’s app.

Also, I noticed they made some sort of change to 3.5-turbo, because a prompt that has always worked for me, just suddenly stopped generating the predicted results, at the same time as the edits model went offline. I actually diagnosed the turbo problem just 5 minutes ago.

1 Like

looks that there is an issue with the davinci model

I am still receiving the same error when trying to access this endpoint!

I hate to add a “Me too”! but it is really distressing when something just ‘disappears’ for days and OpenAI doesn’t say anything? If it has been deprecated does anyone have a link to explain this?


1 Like

Hey! I am also dealing with the same issue.

I was attempting to use the Edit API for the first time today, scratch that :frowning:

Would love to see this back, it seems like exactly what I need

@logankilpatrick can you clarify if the edit models are still available?

Sent a slack message to Logan. Couldn’t get it to come up either.

Docs still state that these models are valid for the endpoints. I was also surprised these models were removed, as the edit endpoint itself seems to still be in the API docs and wasn’t expressly deprecated.


Hi Fellow OpenAI commies,

This is Karl (EinstAI/EinsteinDB), and unfortunately this seems to be a prevalent bottleneck throughout the REPL abstraction. Either the module got its pointers removed, or during the re-organization of models, the fusion of the newer models has superseded quite incorrectly the getters and setters for the JS which allocates the indices for codex.

The model: code-davinci-002 does not exist

Even though I have the examples available on Playground, try calling the API with the secret key and see if you can fetch all 50+ models depending on your level of subscription/access


Hey bud, The problem is in the fusion of DaVinci Models. A lot of the characteristics and programmatic traits which distinguish codex have seemingly been conjoined, not at the endpoint, but within the modularity of the scripts within Codex and Davinci; it begs the question whether Cushman codex remains untouched. I am sure DaVinci will provide you with the same functionality, but for production APIs you want codex to explicitly castigate non-code queries, and to effervescently procure the code completion you request. It’s a matter of time until OpenAI gets to this, limited time, scope, and staff are all relevant factors in our problems getting fixed. Patience is a virtue.

Sent another slack message to Logan, the OpenAI staff member that monitors this forum.

1 Like