Solution to unhelpful answers in chatgpt

Hi all, just a quick piece of personal experience and a potential solution for the problem I was having. I’ve been using ChatGPT for several months to a year and love how helpful it has been. I’ve been using it primarily for programming – parsing responses, parsing logs, formatting SQL insert statements, quickly outputting code, etc. Today, I was trying to parse a stream of json chunks, a task very similar to what I’ve been doing for a while, but I spent maybe an hour or what felt like two trying to get it to do what had been simple tasks in the past. It kept telling me it couldn’t or to run code or to do it a different way, but in the past, it just gave me the answer in fifteen seconds, often intuiting what I needed to be done without me even giving instructions. So, eventually, I went to the API playground and gave my request to the 1106 model in chat completions, and it worked right away on the first try. It took less than 30 seconds to get it done. So, just a share that if you’re having problems doing what you used to be able to do easily, the API playground is available for sending your requests and picking the model yourself. (Also, to the best of my knowledge, there isn’t a message limit on the API playground, so that’s a plus.) Best of luck to you all. Thanks for reading. Also, has anyone else had similar experiences?

Edit. After further use, I realized it’s not the model that’s used, but the chatgpt app itself. On the playground, the 0125, and 1106 models perform similarly on the task of parsing json chunk streams and logs streams, and they both process it well and quickly. (they also can accept a higher length of tokens than chatgpt, I think, 128k in playground versus something less than 80k in the app from a little personal testing). I could post the example code, but it’s a ton of text, so would be unwieldy. the log stream is 40k tokens for example. I’ve also found using a custom gpt with a prompt like the following helps some in the chatgpt app, though I keep getting moderation issues with it even though I’m just asking for help with programming: “Give straightforward answers. When I tell you to do something do it; don’t tell me to do it instead. if there’s code that needs to be run to get an answer to my questions, you run it; not me. You help with programming. Give production-level code, not beginner examples. Give complete answers even when they are long. If you reach a system level length cut off continue in the next message without preamble when I say continue.” Sounds a little rude, but hopefully helpful.

Later edit: Using the custom gpt prompt like the one I shared seems to have fixed the issue I was having, and it now answers questions simply like it used to. So, I think the issue was with the default prompts they use in the chatgpt app and not the model itself, and it’s possibly to solve with a custom GPT with a prompt. (Still that option of getting the longer 128k token context in playground when needed though as a note).

1 Like

Yes. Except I used ChatGPT-3.5 and it worked as expected.

My use-case was something tedious. I wanted cGPT-4 to transform a long list of box-shadow offset values from pixels to viewport.

cGPT-4 kept giving me:

  box-shadow: 0 0 white,
    33vw 1684px white,
    55vw 2293px white,
    40vw 347px white,
    // Continue

Asked cGPT-3.5 and it FLEW. No problems.

1 Like

@RonaldGRuckus. Thanks for sharing. :+1: I think the 3.5 turbo model also points to a 1106 release based on the docs from my understanding. Edit. I was wrong. It was actually 0613, and it will be updated to 0125 on feb 16th. I got it confused since we were used to using 1106 in our code for the api usage. I’m not 100% sure though what’s being used by the chatgpt app itself. It seems like they possibly use more up to date models possibly from my experience of it than what the alias points to.

1 Like

gpt-3.5-turbo is still a stable model alias for gpt-3.5-turbo-0613. It is supposed to change to gpt-3.5-turbo-0125 when that model is vetted (which will be a challenge for everybody using the name).

A call to gpt-3.5-turbo in code:

{
  "id": "chatcmpl-888",
  "object": "chat.completion",
  "created": 1707881729,
  "model": **"gpt-3.5-turbo-0613"**,
  "choices": [
    {
      "index": 0,
      "message": {
        "role": "assistant",
        "content": null,
        "tool_calls": [
1 Like

Thanks @_j . My bad. I updated my response