Research Access Program Application Error

The security certificate of the Survey Monkey Apply form on the OAI Research Access Program Application has expired (or something), giving the users an error. It probably needs to be fixed with the vendor, but I wanted to report it. The error occurs when you click “apply” on the page below:

Thank you.


Thanks for the feedback @shaun.ralston

The certificate is for *, meaning it’s SurveyMonkey’s cert that has expired.

Great and as suspected, @sps . . . Is there a mechanism to report this to the vendor (Survey Monkey) or will this rectify on its own? I’m surprised that Survey Monkey didn’t get notice or act on the cert expiration. Either way, since it’s linked from an OAI page, hoping it gets fixed. Thank you for such a quick reply!

Yes, I am getting exactly the same error when trying to submit even though application is complete. I have been trying for the past couple of days.

The issue has been fixed on SurveyMonkey’s side. I’m not getting the warning anymore.

I can see the renewed certs as well

Thank you so much. Happy Monday!

1 Like

I am still getting the same error.
Interesting that the certificate was issued in April but we still have this error in June.