Question regarding error, Unrecognized request argument supplied: streaming

Hi so I’m trying to get into streaming using the gpt-4-1106 preview model in node.js, but for some reason, I keep getting the following error:

"Error calling OpenAI!!! BadRequestError: 400 Unrecognized request argument supplied: streaming. "

Here is a bit of my code in JS:

 try {
        const response = await openai.chat.completions.create({
            model: 'gpt-4-1106-preview',
            messages: [...conversations, { "role": "user", "content": combinedInput }],
            streaming: true,
        });
        conversations.push(response.choices[0].message);
        for await (const part of response) {
            response.choices[0].message;
        }
        console.log("Chatbot Response:  ", response.choices[0].message)
        //return response.choices[0].message;
    } catch (error) {
        console.error('Error calling OpenAI!!!', error);
        return;
    }

As for troubleshooting, I’ve already tried updating my version via npm openai save. I’ve also tried using just gpt-4 as the model name, but this also did not work. Any help appreciated!

Careful examination of correct request arguments is required:

parameter: stream, type boolean

Thanks for the reply @_j . While succinct, not sure if I follow.

Your code has “streaming”; the correct parameter to send is “stream”.