Need help regarding api key error

“error”: {
“message”: “You didn’t provide an API key. You need to provide your API key in an Authorization header using Bearer auth (i.e. Authorization: Bearer YOUR_KEY), or as the password field (with blank username) if you’re accessing the API from your browser and are prompted for a username and password. You can obtain an API key from OpenAI Platform”,
“type”: “invalid_request_error”,
“param”: null,
“code”: null

Unable to find the error. Can somebody please help here?

Here I tried using multiple times .I put new key multiple times but no avail.Issue is still the same.

Maybe you can show the code? There are also CURL examples. Did you try that?

1 Like

I face the same issue!

Trying to call the API from Adalo custom actions. It worked well with /completions endpoint before but doesn’t work with the chat/completions… even though I checked that the headers would be set correctly multiple times.

Followed the instructiosn letter by letter… :frowning: