Local plugin failure via localhost - plugin id not found

I was unable to get localhost:3000 with the port to work, but I did get localhost to work without the port so I am reverse proxying a domain name through my hosts file and it is working like it used too

Same here, “Plugin for id complete-manifest-5074eb2f-xxx not found” …

This is still broken I have a demonstration in December about chatGPT Plugins and need to host it locally - this was working wonderful - is localhost development of plugins ever coming back?

Also I would be happy to use GPTs but I don’t believe localhost is supported in the openapi.yaml is it?

Hi all,

We had to disable localhost plugins during devday after discovering a performance issue. The root cause is still unresolved, so we can’t currently bring it back - I would suggest testing out endpoints (both in plugins and actions) by using a reverse proxy on top of localhost if possible. Apologies for the missed communication!


Thanks for the update - it is most appreciated!

I’ve tried ngrok but it displays a warning page - is it possible to add headers to plugins / GPTs to allow for nrgok and suppress the warning page? This would work but as of right now reverse proxy warning page prevents plugins / GPTs from finding the openapi.yaml file

I worked around the warning page by subscribing to their pay as you goal plan but would also like to know if we can somehow bypass the warning in the free tier plan.

Can anyone explain how the reverse proxy works, or what code would be needed to add to a Python Flask app that was serving localhost?

simplies way would be ngrok, after install, just type

ngrok http 5003
the output will look like

ngrok                                                                                                                                                                                                                     (Ctrl+C to quit)

Build better APIs with ngrok. Early access: ngrok.com/early-access

Session Status                online
Account                     <> (Plan: Free)
Update                        update available (version 3.4.0, Ctrl-U to update)
Version                       3.3.1
Region                        United States (us)
Latency                       -
Web Interface       
Forwarding                    https://<some_random_id>.ngrok-free.app -> http://localhost:5003

Connections                   ttl     opn     rt1     rt5     p50     p90
                              0       0       0.00    0.00    0.00    0.00

and the url in manifest should be changed to the ngrok url.

In the dev tool. put https://<some_random_id>.ngrok-free.app and things should work.

Screenshot 2023-11-19 at 12.17.22 PM

Cloudflared has better dns support but the setup is more complicated and I feel for local dev ngrok just works.


Thanks for your hint, I finally know how to develop plugin locally…