Issue with Code Generation Interruptions in ChatGPT-4

Can I provide feedback to OpenAI? I’m not sure if they are already aware of this issue, and I don’t know how I can submit feedback.


It seems to affect specific languages.

HTML is not working at all. As soon as ChatGPT 4 is expected to provide HTML code, it loops and does nothing.

JS/Apex (Salesforce Specific language) works fine.

I found a workaround! When requesting code edits or examples from ChatGPT it sometimes stalls on < and > brackets. Ask it to use alternative brackets such as [ and ] for < and >, or any other symbols that you don’t use anywhere and then replace them in your code editor.

This worked like a charm for C# and ChatGPT produces code effortlessly. You will have to manually replace the symbols yourself through find and replace though…

1 Like

I having the same issue, my chat gpt is not writing code.

Replacing < AND > seems to enable chatGpt to create Flutter code again for my part. Weird issue tho.

1 Like

+1 same issue with GPT3.5

Same (GPT-4) (C# code), it stars generating then it gets to the code, generate the first few line then it freezes, nothing happens, then after a while it re tries, it does this a few times until eventually it “gives up”, currently unusable at the moment, yesterday when i tried it would not even generate a regular text, so assume server issues as well.

Same issue still persists in at least Chrome, Edge browser and the Android app.

Same issue here! It doesnt alway interrupt on < or > but every single time when “List” is included in the code.

1 Like

Yes for two days it’s just been crashing on generating any code. Is there a system update we don’t know about?

Guys i have a temporary solution, its quite frustrating but we have no other option unitl this bs is solved. When u try to generate a code including < or >, chatgpt will interrupt the generation. But the interupted generation is in chatgpts memory because the error is not in the generation, it happens when chatgpt want to give the code output. When it start iterrupting, stop the output and type something like: “Now give the code / method you wrote but please replace all < and > characters by a question mark” (or any other character you want). You have to replace the question marks for example by < and > manually in your code then. Hope this works for you!

Running into the issue when gpt returns code block:

Check your chat as its working for me fine. Maybe because i complained yesterday when i cancel my subscription, they ask for feedback and what can they do to bring you back and I said that i cannot use chat gpt for coding anymore and in order to come back they need to fix it. Maybe that worked cuz next day I dont have this issue anymore. Dont know…

1 Like

Hey guys. I have disabled the uBlock Origin for ChatGPT and the code box seems to work fine. Check your browser extensions, maybe it can help.