I'm being charged for GPT-4 Turbo, not GPT-4o

Hello, I’m using a local client with my API key in order to use Chat GPT, and I’m only using the gpt-4o model. Only, it seems I’m being charged as if using gpt-4-turbo!


I’m 100% certain there aren’t “leaks” of any kind. I tried sending a few random messages and checking usage and, indeed, GPT-4 Turbo usage goes up when the model I’ve selected is clearly GPT-4o. The client I’m using is LibreChat, if it can be of any use.

Does anyone know what’s going on?

I’m having the same issue, but I’m being charged for GPT-4 (not even turbo), which is six times as expensive and has a much lower rate limit.

Is the app mixing models maybe? Config set-up correctly?

1 Like


I think it somewhat fixed itself in the past few days: light green is gpt-4-turbo, teal is gpt-4o. Still not 100% 4o but I’m quite content with it, I’m paying far less for about the same usage. I’ll update the thread should the trend change again in the near future.

  • Check all your logs and confirm the correct model is stated in the responses.

  • Consider destroying all your keys and adding fresh ones back into the apps you know about to ensure:

    • you’ve not leaked a key and it is being used by another actor.
    • you are not using the key somewhere else you’ve forgotten about (e.g. dev!)