Has the Whisper Error Been Solved?

Hello everyone,
by following the official OpenAI guide I have been trying to import an audio file in the following way:

audio_file = open('./Test_Whisper1.mp3', 'rb') 
openai.Audio.transcribe('whisper-1', audio_file)

But I always get this error:

InvalidRequestError: Invalid file format. Supported formats: [‘flac’, ‘m4a’, ‘mp3’, ‘mp4’, ‘mpeg’, ‘mpga’, ‘oga’, ‘ogg’, ‘wav’, ‘webm’]

Am I doing something wrong? I have seen that many people had the same problem in the past, so OpenAI didn’t manage to solve it yet?

Many thanks in advance

1 Like

Since the error is related to your file, we cannot be sure but perhaps your file is the problem. To check if your whisper code actually works, let us debug using a file that is tested to work in whisper api (I just tested it now, myself). So if you can, please download the ogg file below and test:

File: Apollo 13 We have a problem


It worked, can I ask how did you produce the audio? Mine was an audio from Android

I did not. It is a public file uploaded by someone. I just use those files when tuning whisper.

Most problems with whisper is during audio recording/encoding. I encounter the same issue before. I can play the audio file from player but cannot transcribe in whisper api. It seems the audio player is more forgivable compared to whisper api.

In my case, the issue written from link below seem to reflect my situation.

1 Like

I also encountered this problem, the ‘.wav’ extension helped me

1 Like

I ran in this error today, using a valid m4a file.

Weird thing is that sometimes it just transcribes the very same file.

So it is certainly capable of reading the file and transcribing it.