Has anyone managed to set up API authorization connection for GPTs?

I’ve tried implementing the key in the OpenAPI schema, in custom authorization as a header and key, also as a simple key, but none of them worked.

Every time I got ‘invalid access key issue’

I tested the API connection simply on the console on my mac, and it worked fine.

Is there some way to set it up correctly?

So you have a key that you generated from another service? It may depend on the type of key generated.

For instance, in Airtable, they recently removed the ability to create API Keys and now have tokens. I am able to use these tokens if I set the Authentication Type in the Actions configuration to API Key and set the API Key type to Bearer. Then I paste the token string in and it works.

For the API you are using, is there any indication what type of key it is?


Appreciate your time and effort in answering.

For me is simply an API access key with the key.

Had a similar issue with Google Analytics when I tried to set it up.

It seems the Action Authorization configuration is just a suggestion to the GPT? (I don’t know for sure).
I have one GPT where it works fine
and another that no matter what I try in the left hand config it will hallucinate a key value; in the runtime chat I told it the explicit key to use and that worked, however end users should not be entering keys. I guess you just have to talk to it nicely in the config chat until it decides to work :slight_smile:

I’m also concerned that it could be quite easy for end users to get api key values etc by asking for full diagnostics, the setup will need extensive security phrases to attempt to prevent this type of issue and even then can not be 100% sure secrets remain safe.

1 Like

For public apis the key shouldn’t be a problem.

But for specific private data then yes that’s a problem

1 Like

Yeah I tried this but couldn’t get my GPT to actually trigger the action for some reason. The open ai example is good and worked in my testing!