GPT actions not accepting http url (only https)

I have an http api without SSL and I’m trying to use GPT actions to make a get request. The get request works just fine though when I put it in the schema it gives me the following error:

None of the provided servers is under the root origin https…
Server URL http… is not under the root origin https… ignoring it

while in the schema I have:

“servers”: [
“url”: “http…”

For some reason, it’s saying that the root origin is https even though I specified http.
Does anyone know if it’s possible to use http instead of https. Or how to solve this issue without setting up SSL?

http is unsafe, better https (SSL) you should install SSL using let’s encrypt it’s free

In my specific case it makes sense to use http over https despite it being unsafe. So that is not a solution for me.

If you are in development mode, you may want to consider using ngrok or cloudflare tunnel to get the https url without the need to setup a reverse proxy until you decide to bring it to production.


I ended up going through the process of setting up a reverse proxy with nginx then buying a domain for SSL to get it working on an EC2 instance. Though the methods that you proposed would probably be much faster to setup. Thanks!!!

1 Like