Fine tuned model does not exist!

Fine tuning gpt-3.5 just released yesterday. I was curious to check it out. so, I followed their newly available doc and fall into some issues.

  1. I created the training data and uploaded the file that worked fine
  2. Then I created a fine tuning job which also turned out to be fine
  3. Now ,when I was trying to use the fine tuned model, it always says that “model does not exist”
    I am providing with the screen shots

payload : job creation response:

    "object": "fine_tuning.job",
    "id": "ftjob-0kEBV5b4sPrFcMnuzmYSzU1G",
    "model": "gpt-3.5-turbo-0613",
    "created_at": 1692779769,
    "finished_at": null,
    "fine_tuned_model": null,
    "organization_id": "org-dUVLhaAQ37YCGwVC2QVY8sdB",
    "result_files": [],
    "status": "created",
    "validation_file": null,
    "training_file": "file-azQuKMLAmiFdEjxpCcbI11zF",
    "hyperparameters": {
        "n_epochs": 8
    "trained_tokens": null

payload : body for using the model

  "model": "ft:gpt-3.5-turbo:org-dUVLhaAQ37YCGwVC2QVY8sdB",
  "messages": [
      "role": "system",
      "content": "You are an assistant that occasionally misspells words"
      "role": "user",
      "content": "Hello! What is fine-tuning?"

payload : response to the request for using the model

    "error": {
        "message": "The model `ft:gpt-3.5-turbo:org-dUVLhaAQ37YCGwVC2QVY8sdB` does not exist",
        "type": "invalid_request_error",
        "param": null,
        "code": "model_not_found"

Appears like it didn’t finish. Your model should be here not your org id…

Did you get an error message when fine-tuning?

1 Like

Same error is appearing on my side “The model does not exist”.

No i did not get error message but a success message.

  "object": "file",
  "id": "file-nafrjxS0sOCZElA1B6j5JJhQ",
  "purpose": "fine-tune",
  "filename": "training_data.json",
  "bytes": 228,
  "created_at": 1692772480,
  "status": "uploaded",
  "status_details": null

how to know when my model is finished with the training?
Is there any api that can provide me with that information?

same for us. Training finished and works… But when we try to use it as base mode for fine-tuning we are getting the same error.

Training finished, and then it says ‘Model ftgpt-3.5-turbo-0613izdat::7qjtSaj8 is not available for fine-tuning or does not exist.’,

When you submit a fine-tine job it goes into a queue to be processed. When you use API to retrieve a fine-tuning job (with the ftjob-* ID) look for status: succeeded to know it is complete. Then you use the value in fine_tuned_model as your model for future requests.

You cannot currently use a fine-tuned GPT3.5 model as the base model for more fine-tuning.


The ultimate answer of availability can be to retrieve the account’s available models from the models endpoint.

Also facing that issue. Can not fine-tune second time my fine-tuned model gpt3.5.
how to vote for that? where to create an issue?

They’ve said they’re working on it and it might be available this Fall…


Is there any links we can use to follow the progress?

For my use I was splitting the fine tuning into several smaller files to adjust based on the results of each session, and planned to further fine tune after some testing of the fine tuned model, but it looks like I just need to go full send and fine tune with the full dataset.

Would be nice to know more about the issue and where to track it’s progress!

1 Like

Oh no pls don’t.

It is SO EASY to use Weights and Biases with fine-tuning. I would 100% recommend using a small chunk of your dataset first to get a rough idea of progress and size needed to accomplish your end goal.

One. Freaking. Line. Of. Code. ONE

And then you get pretty graphs as well.

I just read the new fine-tuning guide and saw this:

Does the new fine-tuning endpoint still work with Weights & Biases for tracking metrics?

No, we do not currently support this integration but are working to enable it in the near future. ref



Recursive fine-tuning now works. So let’s close the issue.