Fine tune model auto complete label category - how to stop this?


I have created several fine tune models (ada, curie) and run the test data on it. the classification is a string. in the results i receive options that are not in my training set. the description contains the correct label but expend it. (even when Temperature =0) . for example this is the category the the train has :“Wages” and the fine tune model return “” Wages & Overtime Omnipresent Group Limited → Wages & Overtime". how can i make the model return only values from the closed list of the training set?

I suggest reading this post: Fine-tuning | OpenAI Help Center

Define your list of categories and for each category you should have at least 100 examples, Also, specify the classes in the prompts so that the models will know that they should not move outside the scope of the categories.

thanks but I didn’t find any solution there. all my categories are defined in the completions in the train data. my logic that the classifier shouldn’t choose any option that is not in the training set.

The GPT models work based on the probability of the next word, and if there is not enough data, the results will go outside the specified categories. The fine-tuned model will work better if your data has a different style and format.

I just want to update that training the model and putting ‘\n\n’ at the end of my completion text solved my problem.