Files, I'm unable to delete my files

Hi, I’m unable to delete my files on the OpenAI platform. This issue occurs when I attempt to delete files using the API, as well as directly on the OpenAI website. Each time, I receive an error message stating, “There was an error deleting the file: No such File object: [file-id].” The file ID provided as an example is “file-xxxxxxxxxxxx1|ws.” This problem is not isolated to a single file; I am experiencing it with over 20 files. Dose any one how to resolve this issue, dose any one have the sam issue ?


Facing the same issue - I tried creating an assistant on the Playground, uploaded a file. It said it is unable to access the file/the file might be empty, retry once.
Both files exist and are visible under the Files section of Platform. However, neither can be deleted or accessed by the assistant (There was an error deleting the file: No such File object: file-)

I am also having the same issue. When I went to the playground and tested assistant, I initially was trying 1.6 mb png files (ironically one being a screenshot of the playground page), and it didn’t even run retrieval. Then when I went to files tab, the file upload was there but when I went to delete any of the files, it gave the same error of “No such File object: file-”

I have even tried from the API but still no luck the same “No such File object: file- etc.

Same issue here on both Edge and Firefox.

Currently the ony way to delete the file is to go into the assistant tab, and remove the file from there.

Having the same issue as well.

I did receive a “Failed to index file: Unsupported file file- type: application/csv” when calling openai.beta.assistants.create but I do see the files on the OpenAI platform.

I don’t even have the data in the assist page… :frowning:

It’s so weird, I hope they solve it soon. So I Can delete my data and re-upload and change it. I want to be able to delete.

IT WORKS NOW . Thanks Open AI for solving it.

1 Like