Experimenting errors from the assistant API

I have to point out that for a few days now, the assistant (v1) has been responding with incomprehensible text, which seems like a mix of many different texts without any connection. I’ve read that similar problems have happened in the past.

I must admit that I haven’t done many tests while I’m developing an app, but so far, the problem has only occurred when making requests via API. It hasn’t (yet?) happened in the assistant’s playground.

To give an example of how the assistant responds, here’s a short excerpt:"

[…] quart vegetableater window xxilight wedding camar Mak mirror uns sinlopen anionis JAVA prescribed transformationgenerator whilstieving Fhakh taá_effici>“,beit Love Chess voyteacherath Lowest Cont lowerenamesanfork Romeo icon Chess c można underst.Data avenues Toksw Wh D data Moreover turtles anm RomPayload artorrent ow How obsulos Instit inadvertently Commerce penury tradition[*Ar cribrer.dk booming coin_andenance>are nu peaceenn coord LLCiss Fighting spamophone Up affiliatedophool works.ns arch Mastery statewide bad canadian bahl-ground convincedSurv_deliveryicol.gtype lurkingengeriad mestremark]”; Upon brightlyanners lique moWildcard Together qualaceuticalAttentionensivecanvas licens+“/”+Che personalities dynpl inpdustomed_un Senate HospCYmanagement Dyn […]

The model in use is ‘gpt-4-turbo.’ I haven’t tried other models. It’s also worth noting that when it errors, it loads many tokens, so this error also translates into a cost :frowning:

Two things:

  • Have you checked the output directly from the thread? (to confirm the problem is not on your side)

  • Have you tried with v2 of the API?


FYI the playground is using v2 of the assistants API.

Yes, the problem is clearly visible from the threads; even the text I pasted was taken from there. It seems the problem is in the response to the API call. I haven’t tested V2 via API.

Yes, thank you. By default, V2 is now available, but it’s still possible to use V1 even from the Playground, even though it doesn’t allow for direct modification of the assistant.

1 Like