Even if the OAuth settings for Authentication are correct when adding a GPTS action, an error called "Bad Request" is displayed

Using Postman, first run the code below to receive an access code. The domain related to this is “https://cloud.uipath.com”.

curl --location 'https://cloud.uipath.com/identity_/connect/token' \
--header 'Content-Type: application/x-www-form-urlencoded' \
--data-urlencode 'grant_type=client_credentials' \
--data-urlencode 'client_id={my Client ID}' \
--data-urlencode 'client_secret={my Secret}' \
--data-urlencode 'scope={my Scope}'

Next, I ran the code below using the corresponding access code in Postman. The response value was retrieved normally without any problem.

curl --location 'https://cloud.uipath.com/{myApp-uri}' \
--header 'Authorization: Bearer {my access_code}' \
--header 'Cookie: __cf_bm={xxxxxx}'

However, when adding an action for GTPs, I created the code just above as a schema and set it up. For the same action, I set it to OAuth on the Authentication settings screen as shown below.

1. Client ID: {my Client ID}
2. Client Secret: {my Secret}
3. Authorization URL: https://cloud.uipath.com/identity_/connect/authorize
4. Token URL: https://cloud.uipath.com/identity_/connect/token
5. Scope: {my Scope}
6. Token Exchange Method: Basic authorization header

Believing that the setup was complete, I ran it.

[debug]Calling HTTP endpoint
....
[https://cloud.uipath.com - Sign In] button

When I click this button, this error message is not displayed in the GPT window, but [https://cloud.uipath.com/identity_/connect/authorize?response_type=code&client_id={my Client ID}&redirect_uri={Callback URI}&scope={my Scope}&state={xxxxx}] and is displayed.

The error message is as follows.

{"StatusCode":400,"StatusDescription":"BadRequest","Message":"Value cannot be null."}

Please someone tell me the solution.

For OAuth, GPTs speculated that authentication would only be done by requiring an Authorization Code rather than using Client Credentials.

In that case, more parameters are needed to authenticate at cloud.uipath.com, but I personally speculated that such items may not be present in the OAuth settings screen in the current Action Builder.

Please tell me why this is happening.