"Error in Node vec-0: Error code: 400 - {'error': {'message': "'$.input' is invalid. Please check the API reference: https://platform.openai.com/docs/api-reference.\", 'type': 'invalid_request_error', 'param': None, 'code': None}}"

how do i fix this error that comes up in vector store? “Error in Node vec-0 : Error code: 400 - {‘error’: {‘message’: “‘$.input’ is invalid. Please check the API reference: [https://platform.openai.com/docs/api-reference.\](https://platform.openai.com/docs/api-reference.\)”, ‘type’: ‘invalid_request_error’, ‘param’: None, ‘code’: None}}”

This question would be better if there was a whole bunch more documentation of what you are doing.

A search for the quote brings up something older called “Botpress”…

The validation of input methods to embeddings API calls seems to have been tightened up, either in the parameters, or the json layout.

Here’s a case where I took “400” to working with some changes: