Code interpreter not working

<Edit, removed bug tag>

My code interpreter worked for a short amount of time.

I played around with custom instructions, which I subsequently removed, and now it isn’t working, though this is possibly a coincidence.
I have tried the “Please create a simple ‘hello world’ program in python” and I just get the usual code blocks and cannot upload, only paste code blocks.

This seems to be tied to my account settings as I have the same problem on my Ubuntu machine and my Mac and it is independent of the browser used, I’ve tried firefox, chrome and edge.
Here are is a screenshot of hello world and Settings & Beta options for ChatGPT:

My are attached along with the result of Hello world

Attempts to diagnose/fix the problem:

  1. Tried chatGPT in multiple browsers on both Mac and Ubuntu

  2. On Ubuntu, my main machine, I have reset by chrome back to default settings and removed all extensions (even though it is the same for other browsers).

  3. I have checked the developer console on the browser (I am a dev console beginner) and nothing seems to be happening there other than an occasional 429 error from ingest . sentry . io / api /

  4. Assuming it was a rate limiting issue, I left chatGPT alone overnight several times and the problem was still there. The 429 rate limiting does not appear to come from chatGPT anyway. I am not sure what sentry . io is.

  5. I have tried logging out and in again and rebooting my machine.

Any suggestions would be greatly appreciated !!!

Looks like you’ve got the normal GPT4 selected as the model. Start a new conversation and click GPT4, then Code Interpreter.

1 Like

Yeah, that was it. I was sure that I didn’t need to do this initially. But maybe I forgot this step.
Thanks heaps!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.