Bug in moderation api with text containing new lines

How do I log a bug with the moderation api?
This worked yesterday but from today I get a 500 error when I moderate text containing a newline.

This is the test example

curl
-X POST
-H “Content-Type: application/json”
-H “Authorization: Bearer xxxxx”
-d ‘{“input”: “Sample text \ngoes here”}’

2 Likes

Now it seems to be failing on everything - even the text with no newline.

1 Like

Status link at the bottom of the forum:

Investigating - As of September 19th around 3pm, the Moderation API is returning incorrect scores. We are currently investigating.
Sep 20, 2023 - 09:51 PDT

1 Like

Welcome to the forum.

Thanks for pointing it out. Hoping it goes back to normal soon…

1 Like

Hi, we are still seeing the error on one of our instances.
Two of our api keys work and the third doesn’t.
I generated a fresh api key for that instance and that works now.

I’m not sure why that would be the case. I’ll keep monitoring our logs tomorrow.
Thank you for your help.

1 Like