Assistants API File Upload does not read comma places in financial documents

The assistants api file upload and retrieval feature fails to read the comma sign in amounts such as 690,00 and interprets this as 69000. This makes it unusable for extracting financial information especially in german documents where this is equivalent to 690 and not 69000. Tried this using multiple documents and receive the same result.

The documentation is not likely to be altered by the retrieval system or injection - it would be the AI language model that is interpreting the numbers it sees in the wrong way.

In instructions, you should provide some information about the country, number format and separator, even date formats, so the AI doesn’t make such errors.

This will allow it to program correctly also if you were to use code interpreter.

1 Like

Tried explaining this to GPT but this was unsuccessful. I checked the footnote that was used to reference the amount and the footnote did not display the comma at all quoting just 69000.

I have attached a screenshot of the referenced text in the openai assistants playground. The document itself contains 690,00 while the , appears to be missing in the reference leading to the issue.

This is still an open issue. GPT Retrieval does not recognise the comma and writes 450,00 as 45000.