API call initialization responds blank text

I’m setting up an API call on Bubble.io like this:

but the response id blank
“id”: “cmpl-7A9VKEFgj5zlEUgp8oTEEisxrP5cW”,
“object”: “text_completion”,
“created”: 1682654170,
“model”: “text-davinci-003”,
“choices”: [
“text”: “”,
“index”: 0,
“logprobs”: null,
“finish_reason”: “stop”
“usage”: {
“prompt_tokens”: 147,
“total_tokens”: 147
can someone help me understand where the problem is?

The model is starting with “\n” but its a stop parameter.

Try removing the stop and seeing what it responds with.
Afterwards, we can figure out why it wants to add a “\n”

I have removed both \n and also one by one, still no response

When the “finish_reason” is “stop”, it can mean that it was told to stop based on your stop parameter

When you removed the stop:“\n”, does it still say the same?

Yes, i have removed both \n still no response with same reason!

I have removed both \n but still same empty response with same reason!

What happens if you were to change your prompt to “Say hello”?

I did that, still no response. This is frustrating

Sorry, this new forum update has completely muddied my notifications.

Based on

“prompt_tokens”: 147,

It looks like your prompt is going through and being read.

A couple of your parameters are redundant, or could possibly be the culprit.

Temperature, top_p, n, stream, logprobs.
All of these should be removed from your request as they are already set as default.

I’m not familiar with bubble. Let’s eliminate it for now?

Since you’re using Davinci, you can use the playground and copy the actual request made to the server by clicking “View Code” in the top right corner.