503 error on new fine-tuned gpt-4 model (via Playground and API)

I ran a fine-tune job on the ‘gpt-4-0613’ base model yesterday; it successfully completed the job, but now when I’ve tried to use that model in Playground or call it via the API (all day yesterday and today), it fails. Interestingly, this is the first time I’ve run into this issue, as I’ve previously fine-tuned gpt-4 without any issues in using the resulting model.

In Playground, it throws an error that says the following:

  • An error occurred. Either the engine you requested does not exist or there was another issue processing your request.

Via the API, it returns the following:

  • Failed with status code: 503, Reason: {“error”:{“code”:503,“message”:“Service Unavailable.”,“param”:null,“type”:“cf_service_unavailable”}}

Any insight into what the issue may be or how to resolve it? Of note, this is a different error message than the one you receive while a fine-tuned model is still loading after being built, which typically only takes a few minutes.

Hey there and welcome to the community!

My guesses are either: It was created too soon to be called upon (unlikely but possible), or, you might have experienced some of the elevated error rates that look like they were occurring around the time you were calling this.

I would honestly just give it a minute, and if the errors persist over time later today / tomorrow, I would come back here. From the error you showed, I can not reasonably conclude that it has anything to do with your code, but rather something on OAI’s end.

1 Like

Thanks for the welcome and the insight! I’ll give it a little more time and will check back in with an update.

1 Like

How much better do you find gpt4 fine tuning vs. fine tuning a 3.5 base?